View Issue Details

IDProjectCategoryView StatusLast Update
0003018SketcherBugpublic2019-07-30 22:45
ReporterPatolaAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0003018: Sketcher Arc End Points + Rim Point fails with "NaN"
DescriptionIn certain situations, creating an arc from end points then rim point does not work, showing Not-a-Number. The attached file has such a situation. It occurs in FreeCAD 0.16 and latest 0.17 from PPA. The steps to reproduce tell the problem in a little more detail.
Steps To Reproduce1 - Open the attached fcstd file. It has a square sketch 600x600mm padded to 20mm, then a sketch with two 60x60mm squares equidistant from the sides by 20mm and padded to 600mm, then a third sketch with corner points of the second sketch squares marked as external geometry.
2 - edit the third sketch. Make a construction line between the points and then a point in the middle of it (equidistant from the points).
3 - add a vertical construction line, 40mm in length, from this median point to below.
4 - select the arc tool - End points and rim point.
5 - select the leftmost external geometry point. Then select the rightmost external geometry point.
6 - Now instead of the cursor having the distance numbers for you to choose the third (rim) point, you have it showing -nanR for distance, -nandeg for angle. A screenshot is attached showing this. It works the same way in FreeCAD 0.16 from PPA and FreeCAD 0.17 from freecad-daily PPA.
7 - if anyway I click on the third point I want for the rim, it says the sketch is overconstrained and marks all constraints as invalid. And does not create the arc.
http://storage9.static.itmages.com/i/17/0424/h_1493030746_6060157_d914be8b56.png
Additional InformationOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6707 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 5465bc47c95db45e0be85dc0e2872419efadce0f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=22512
TagsNaN

Relationships

related to 0002997 closedabdullah External geometry points make arc ends become NaN 

Activities

Kunda1

2017-05-01 12:13

administrator   ~0008839

@Patola please re-add test file and screenshot. Thx!

Kunda1

2017-05-04 10:41

administrator   ~0008883

@NormandC do you mind confirming this ticket?

Patola

2017-05-05 04:56

reporter   ~0008886

Why were my screenshot and freecad file removed? I fortunately had them at the time mantisbt crashed and that's the second time I open this very bug (it was opened prior to the crash, so it was not backed up) and I reused them, but I do not have the screenshot anymore.

bug-sweep-017.fcstd (271,630 bytes)

Patola

2017-05-05 05:00

reporter   ~0008887

Found my screenshot on issue 0002997. Attaching it again

arco.png (271,532 bytes)
arco.png (271,532 bytes)

Kunda1

2017-05-06 11:01

administrator   ~0008894

@Patola our bugtracker was compromised and some attchments didn't survive the backup. Thx for your patience.

Kunda1

2017-05-07 14:38

administrator   ~0008901

@Patola FYI you're subject to getting faster response by posting to the forum first before opening a ticket. The recommendation is opening an accompanying forum thread to discuss the issue.

normandc

2017-05-14 00:44

manager   ~0008998

The bug description mentions
Patola wrote

1 - Open the attached fcstd file. It has a square sketch 600x600mm padded to 20mm, then a sketch with two 60x60mm squares equidistant from the sides by 20mm and padded to 600mm, then a third sketch with corner points of the second sketch squares marked as external geometry.

The "bug-sweep-017.fcstd" file has no such sketches.

Patola

2017-05-14 00:53

reporter   ~0008999

Sorry... I don't know what happened. You can use the file from 0002997. I am attaching it here.

And sorry for not opening a topic on the forum. I think I am just too used to report in the bugtracker. That's not the first time I am warned about that.

arc-end-points-and-rim.fcstd (11,223 bytes)

normandc

2017-05-14 00:54

manager   ~0009000

Okay, I rebuild a new model from scratch based on the bug description, and was able to replicate the issue.

In the atached file, edit Sketch002 and start from step 4.

Bug confirmed on

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11054 (Git)
Build type: None
Branch: master
Hash: 36c60d3f8d924799e805ce56cb6e8fe6e49cf12b
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0

FC017_Patola_bug3018_normandc1.fcstd (24,066 bytes)

normandc

2017-05-14 01:06

manager   ~0009001

Well I should have waited a bit it seems!

Still, not related to this bug, but 0.17 reports conflicting constraints in your Sketch002. The point is not even necessary, just create a symmetric constraint between the horizontal line itself and the small vertical line upper end point. 0.16 reports no error, which seems to indicate the sketcher solver has improved in 0.17.

The NaN bug only occurs if the first two selections are constrained to existing geometry points. If clicked randomly on the screen, it does not happen.

normandc

2017-05-14 01:13

manager   ~0009002

This issue seems to be reproducible only when constraining the two first points of the arc on a horizontal line. If the line isn't horizontal, there is no bug. No bug with single points, or circle centre points, etc.

Simply create a new document, new sketch, trace a horizontal line; then start the arc from 3 points tool, click on the two end points of the line for the first two selections.

Kunda1

2017-05-18 11:28

administrator   ~0009049

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=22512

abdullah

2017-05-20 17:33

manager   ~0009066

The solution given in the code is bad conditioned for this specific case, which leads to NaN results.

I will work towards a solution

abdullah

2017-05-21 08:09

manager   ~0009069

https://github.com/FreeCAD/FreeCAD/pull/766

Kunda1

2017-05-26 22:30

administrator   ~0009161

FreeCAD master c6e0c6aa

wmayer

2017-05-27 13:00

administrator   ~0009169

https://github.com/FreeCAD/FreeCAD/commit/c6e0c6aa80ebae7ad0fd5269592d34dded872c8a
https://github.com/FreeCAD/FreeCAD/pull/767

Related Changesets

FreeCAD: master c6e0c6aa

2017-05-21 12:32:02

Abdullah Tahiri


Committer: wmayer Details Diff
fixes 0003018 Affected Issues
0003018
mod - src/Mod/Sketcher/Gui/CommandCreateGeo.cpp Diff File

Issue History

Date Modified Username Field Change
2017-05-01 12:11 Kunda1 New Issue
2017-05-01 12:13 Kunda1 Reporter Kunda1 => Patola
2017-05-01 12:13 Kunda1 Note Added: 0008839
2017-05-04 10:41 Kunda1 Note Added: 0008883
2017-05-05 04:56 Patola File Added: bug-sweep-017.fcstd
2017-05-05 04:56 Patola Note Added: 0008886
2017-05-05 05:00 Patola File Added: arco.png
2017-05-05 05:00 Patola Note Added: 0008887
2017-05-06 11:01 Kunda1 Note Added: 0008894
2017-05-06 11:02 Kunda1 Relationship added related to 0002997
2017-05-07 14:38 Kunda1 Note Added: 0008901
2017-05-07 14:38 Kunda1 Status new => feedback
2017-05-14 00:44 normandc Note Added: 0008998
2017-05-14 00:53 Patola File Added: arc-end-points-and-rim.fcstd
2017-05-14 00:53 Patola Note Added: 0008999
2017-05-14 00:53 Patola Status feedback => new
2017-05-14 00:54 normandc File Added: FC017_Patola_bug3018_normandc1.fcstd
2017-05-14 00:54 normandc Note Added: 0009000
2017-05-14 01:06 normandc Note Added: 0009001
2017-05-14 01:13 normandc Note Added: 0009002
2017-05-14 13:40 Kunda1 Status new => confirmed
2017-05-14 13:40 Kunda1 Tag Attached: NaN
2017-05-18 11:28 Kunda1 Additional Information Updated View Revisions
2017-05-18 11:28 Kunda1 Note Added: 0009049
2017-05-20 17:33 abdullah Note Added: 0009066
2017-05-20 17:33 abdullah Assigned To => abdullah
2017-05-20 17:33 abdullah Status confirmed => assigned
2017-05-21 08:09 abdullah Note Added: 0009069
2017-05-26 22:30 Kunda1 Note Added: 0009161
2017-05-27 13:00 wmayer Status assigned => closed
2017-05-27 13:00 wmayer Resolution open => fixed
2017-05-27 13:00 wmayer Fixed in Version => 0.17
2017-05-27 13:00 wmayer Note Added: 0009169
2019-07-30 22:45 Kunda1 Changeset attached => FreeCAD master c6e0c6aa