View Issue Details

IDProjectCategoryView StatusLast Update
0003017FEM[FreeCAD] Featurepublic2017-06-24 07:08
ReporterHoWil Assigned Toberndhahnebach  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0003017: highlighting of selected elements in FEM-wb
DescriptionIt would be extremely helpfull if elements like faces of solids selected for meshing (e.g. face selection in mesh-region) or constraint-assignment be highlighted when re-selecting them in the appropriate Task menu.
The behavior is similar to the selection of elements int Tree-view. When selecting a Part-box in tree-view, the box is highlighted in 3D-view.

For mesh-regions and mesh-groups is it otherwise not possible to see which elements were selected/added in Task-view.
Constraints do get at least symbols in 3D but it is not directly possible to figure out which element listed in task-view is which element in 3D.

For non-covered elements in 3d is a workaround to hover the mouse over the elements to see their names in the status line but this is not working for inner selections.

The behavior should be like in the attached screenshots. After selecting a element like 'Face2' in Task view it is highlighted in 3D.

See also the related discussion in the forum:
https://forum.freecadweb.org/viewtopic.php?f=18&t=18780&hilit=clipping&start=30#p147758
Additional InformationRelated macro is:
https://forum.freecadweb.org/viewtopic.php?f=18&t=12381&p=151950#p151950
TagsNo tags attached.
FreeCAD Information

Activities

Kunda1

2017-05-01 12:06

administrator   ~0008838

@HoWil please re-add both screenshots, thx!

HoWil

2017-06-14 08:46

developer   ~0009361

Re-added (new) screenshots of selected Face2 without and with highlighting of the selected element.

HoWil

2017-06-14 09:03

developer   ~0009362

CfdFoam-wb already has this feature implemented see....
https://github.com/jaheyns/CfdFoam

Kunda1

2017-06-14 12:28

administrator   ~0009363

@HoWil do you mind specifying where in the source code the feature is located? thanks!

berndhahnebach

2017-06-16 04:40

developer   ~0009401

may be helpful ...

https://forum.freecadweb.org/viewtopic.php?f=22&t=16875
https://forum.freecadweb.org/viewtopic.php?f=8&t=17693#p139340

berndhahnebach

2017-06-16 04:42

developer   ~0009402

What exactly would be best? My idea:

- if the constraint is opened mark all referece shapes of the conxtraint by a color
- if a reference shape is selected in the task panel it is marked by another color

berndhahnebach

2017-06-16 04:44

developer   ~0009403

workaround:
As a hint, if the status line is activated and the mouse is moved over the shapes in the main window the shape names are printed in the status line. This helps to indicate which shape should be removed if one would like to remove a specific shape.

bernd

berndhahnebach

2017-06-16 04:45

developer   ~0009404

Last edited: 2017-06-16 04:45

View 2 revisions

@HoWil do you mind specifying where in the source code the feature is located? thanks!

Kunda1


+1 I'm curious

berndhahnebach

2017-06-21 16:02

developer   ~0009485

Last edited: 2017-06-21 16:03

View 2 revisions

From my point of view the Constryaint Fixed has something in this regard already. If a edge or face in task panel in Constraint Fixed reference shapes is selected the shape is selected in the Main window with the model.

Is this what you would like to see in all conatraints HoWil?

HoWil

2017-06-23 19:50

developer   ~0009492

Last edited: 2017-06-23 20:05

View 2 revisions

I would like to add an screencast of how it works in CFDFoam but it looks like I am not allowed to upload .webm or .zip.

Is there a reason why the two last pics from my where deleted?

EDIT: I like both, the colors for the groups and the highlighting for the selected item in the task view.
The selection via list is a long therm must have when you think of inner boundaries and models with hundrets of boundaries.

HoWil

2017-06-23 20:16

developer   ~0009493

https://github.com/jaheyns/CfdFoam/blob/master/_TaskPanelCfdFluidBoundary.py

@Kunda: I think this is the file used to create the 'advanced' boundary selection menu. 'faceHighlightChange' is used to highlight the selected items in the task view.

berndhahnebach

2017-06-23 21:33

developer   ~0009496

https://github.com/berndhahnebach/FreeCAD_bhb/commit/7d3b8c45d60026c461160a7f1e2dc54119a29aeb

but it needs some more love ...

berndhahnebach

2017-06-23 23:36

developer   ~0009497

this should do the trick:
https://github.com/berndhahnebach/FreeCAD_bhb/commit/6cf727c9a2d86c3030541de5995c3a4a70b5a2a1

but it needs a bugfix too:
https://github.com/berndhahnebach/FreeCAD_bhb/commit/728fba763c25479f4103d9f1d5508494f3ad5fbf

both are in https://github.com/berndhahnebach/FreeCAD_bhb/commits/femdev

berndhahnebach

2017-06-23 23:43

developer   ~0009498

https://github.com/FreeCAD/FreeCAD/pull/835

berndhahnebach

2017-06-23 23:43

developer   ~0009499

I'm gone add the other Python Constraints once this is in master and has been proved to work for a few days.

HoWil

2017-06-24 06:59

developer   ~0009501

I did test it with your femdev branch.

It's exactly what I requested!
I will close this request and open an separate one for the list selection.

Thx
Howil

HoWil

2017-06-24 07:08

developer   ~0009502

tested it in femdeb branch of bhb. Faces are highlighted after selecting them in Task view.

Issue History

Date Modified Username Field Change
2017-05-01 12:03 Kunda1 New Issue
2017-05-01 12:03 Kunda1 Status new => assigned
2017-05-01 12:03 Kunda1 Assigned To => berndhahnebach
2017-05-01 12:05 Kunda1 Reporter Kunda1 => HoWil
2017-05-01 12:06 Kunda1 Note Added: 0008838
2017-06-14 08:46 HoWil File Added: Screenshot from 2017-06-14 10-44-24.png
2017-06-14 08:46 HoWil File Added: Screenshot from 2017-06-14 10-44-11.png
2017-06-14 08:46 HoWil Note Added: 0009361
2017-06-14 09:03 HoWil Note Added: 0009362
2017-06-14 12:28 Kunda1 Note Added: 0009363
2017-06-16 04:40 berndhahnebach Note Added: 0009401
2017-06-16 04:42 berndhahnebach Note Added: 0009402
2017-06-16 04:44 berndhahnebach Note Added: 0009403
2017-06-16 04:45 berndhahnebach Note Added: 0009404
2017-06-16 04:45 berndhahnebach Note Edited: 0009404 View Revisions
2017-06-21 16:02 berndhahnebach Note Added: 0009485
2017-06-21 16:03 berndhahnebach Note Edited: 0009485 View Revisions
2017-06-21 19:15 Kunda1 Status assigned => feedback
2017-06-23 19:50 HoWil Note Added: 0009492
2017-06-23 19:50 HoWil Status feedback => assigned
2017-06-23 20:05 HoWil Note Edited: 0009492 View Revisions
2017-06-23 20:16 HoWil Note Added: 0009493
2017-06-23 21:33 berndhahnebach Note Added: 0009496
2017-06-23 23:36 berndhahnebach Note Added: 0009497
2017-06-23 23:43 berndhahnebach Note Added: 0009498
2017-06-23 23:43 berndhahnebach Note Added: 0009499
2017-06-24 06:59 HoWil Note Added: 0009501
2017-06-24 07:08 HoWil Status assigned => closed
2017-06-24 07:08 HoWil Resolution open => fixed
2017-06-24 07:08 HoWil Fixed in Version => 0.17
2017-06-24 07:08 HoWil Note Added: 0009502