View Issue Details

IDProjectCategoryView StatusLast Update
0003007TechDraw[FreeCAD] Featurepublic2018-01-05 21:27
ReporterKunda1Assigned Towandererfan 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0003007: TechDraw - Projection Group
DescriptionThe Projection Group continues to be exasperating. The current version is restricted to "cardinal" directions (Front,Back,Top,Bottom,Left,Right) and their associated iso views and relies on large tables of view directions and rotations. There are almost certainly typographic errors in these tables. A proper geometric solution that supports arbitrary view directions is required.

In addition the Projection Group can be painfully slow to recalculate - much slower that equivalent individual views.
(https://www.freecadweb.org/wiki/index.php?title=TechDraw_Roadmap)
TagsNo tags attached.

Activities

wandererfan

2018-01-05 00:28

developer   ~0010707

This ticket is obsolete. DrawProjGroup has been extensively modified since this ticket was opened. Can't point at a specific commit.

Kunda1

2018-01-05 21:27

administrator   ~0010714

Closing

Issue History

Date Modified Username Field Change
2017-04-29 15:11 Kunda1 New Issue
2017-04-29 15:12 Kunda1 Project FreeCAD => TechDraw
2018-01-05 00:28 wandererfan Note Added: 0010707
2018-01-05 21:27 Kunda1 Assigned To => wandererfan
2018-01-05 21:27 Kunda1 Status new => closed
2018-01-05 21:27 Kunda1 Resolution open => fixed
2018-01-05 21:27 Kunda1 Fixed in Version => 0.17
2018-01-05 21:27 Kunda1 Note Added: 0010714