View Issue Details

IDProjectCategoryView StatusLast Update
0003006PartDesignBugpublic2017-06-16 00:04
Reporterkkremitzki Assigned Tokkremitzki  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003006: PartDesign Mirrored features fail due to unexpected inversion
DescriptionThe Mirrored feature is inverted in two ways. For example, a cube at the origin mirrored about the vertical sketch axis is being mirrored about the horizontal axis instead. Additionally, it is mirrored on the other side of the plane of padding.
Steps To ReproduceCreate a document and switch to PD WB.
Create a body and add a sketch to any plane.
Fix a rectangle to the origin and then stretch it out to some distance;
lock that point to constrain the sketch.
Pad it. Click on the padded feature.
Click the Mirrored button.
Observe the bug.
Additional InformationOriginal thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=21694&p=169385#p169385
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0002235 closedkkremitzki Cannot mirror mirrored object (within Part Design) 
related to 0002863 assignedickby Add Mirror body feature to PartDesign 

Activities

Kunda1

2017-05-02 11:32

administrator   ~0008850

Is this a dupe of 0002235 ?

kkremitzki

2017-05-22 12:34

administrator   ~0009078

@Kunda1 I don't think it can be said for sure until this one is fixed. It may be that that bug is being caused by an issue with mirroring a mirrored object specifically, rather than the fact that mirroring is broken in general.

kkremitzki

2017-05-25 13:35

administrator   ~0009132

My explanation is maybe not too clear, so here's a screenshot.

Note the coordinate vectors in the bottom right. This cube should be getting mirrored about the Y axis.

3006.png (205,914 bytes)
3006.png (205,914 bytes)

kkremitzki

2017-06-12 07:15

administrator   ~0009350

Will be fixed with FreeCAD Pull Request 818

kkremitzki

2017-06-16 00:04

administrator   ~0009395

Fixed in master

Issue History

Date Modified Username Field Change
2017-04-29 15:05 Kunda1 New Issue
2017-04-29 15:05 Kunda1 Status new => assigned
2017-04-29 15:05 Kunda1 Assigned To => kkremitzki
2017-04-29 15:06 Kunda1 Reporter Kunda1 => kkremitzki
2017-05-02 11:28 Kunda1 Relationship added related to 0002235
2017-05-02 11:29 Kunda1 Relationship added related to 0002863
2017-05-02 11:32 Kunda1 Note Added: 0008850
2017-05-22 12:34 kkremitzki Note Added: 0009078
2017-05-25 13:35 kkremitzki File Added: 3006.png
2017-05-25 13:35 kkremitzki Note Added: 0009132
2017-06-12 07:15 kkremitzki Note Added: 0009350
2017-06-16 00:04 kkremitzki Status assigned => closed
2017-06-16 00:04 kkremitzki Resolution open => fixed
2017-06-16 00:04 kkremitzki Fixed in Version => 0.17
2017-06-16 00:04 kkremitzki Note Added: 0009395