View Issue Details

IDProjectCategoryView StatusLast Update
0002995SketcherFeaturepublic2017-05-02 10:48
Reporternormandc Assigned Toabdullah  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002995: Sketcher horizontal/vertical constraints: implement their use to align points
DescriptionThis report proposes for horizontal and vertical constraints to support selection of two or more points.

Currently, the only valid selection is line segment(s). It would be very useful to be able to align points from independent elements (lines, arc/circle centre points) either horizontally or vertically. Currently, the only way of doing that is to either add a horizontal/vertical dimensional constraint of zero value (which is not considered good practice) or a construction line joining the two points (which adds complexity to the sketch).

Other constraints already support dual modes: tangent constraint doubles as a collinear constraint between lines, equal length constraint can work on arc/circle radii; therefore this implementation would comply with the sketcher philosophy.
Additional InformationSee forum topic: https://forum.freecadweb.org/viewtopic.php?f=3&t=21590
TagsNo tags attached.
FreeCAD Information

Activities

kkremitzki

2017-04-02 10:17

administrator   ~0008748

Sketch::addHorizontalConstraint source

Sketch::addVerticalConstraint source

Kunda1

2017-04-26 02:54

administrator   ~0008768

@abdullah wrote:
implemented.
https://forum.freecadweb.org/viewtopic.php?f=10&t=21878&p=170615#p170615

----------------
Was it in fact implemented?

FYI ticket thread was recreated from previous ticket.
CC @DeepSOIC

abdullah

2017-04-26 16:49

manager   ~0008779

It is indeed implemented. It is not merged yet. It is waiting in my computer for the merge of this PR:
https://github.com/FreeCAD/FreeCAD/pull/696

The reason is that it will conflict with it. As soon as that one is merged, I will rebase it to master and do a PR.

Kunda1

2017-04-28 02:06

administrator   ~0008787

Per Abdullah, commit is pending on FreeCAD Pull Request 696

abdullah

2017-04-30 16:58

manager   ~0008834

https://github.com/FreeCAD/FreeCAD/pull/720

wmayer

2017-05-02 10:41

administrator   ~0008846

git show cfc2d8 40c6d4b 7bee2c5

Kunda1

2017-05-02 10:46

administrator   ~0008847

FreeCAD master cfc2d86c
FreeCAD master 40c6d4be
FreeCAD master 7bee2c54

Related Changesets

FreeCAD: master cfc2d86c

2017-04-20 14:54:26

abdullah


Committer: wmayer Details Diff
Sketcher: Horizontal alignment constraint command Affected Issues
0002995
mod - src/Mod/Sketcher/Gui/CommandConstraints.cpp Diff File

FreeCAD: master 7bee2c54

2017-04-20 14:54:57

abdullah


Committer: wmayer Details Diff
Sketcher: Visualization of horizontal alignment constraint Affected Issues
0002995
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

FreeCAD: master 40c6d4be

2017-04-20 15:04:35

abdullah


Committer: wmayer Details Diff
Sketcher: Vertical alignment constraint command Affected Issues
0002995
mod - src/Mod/Sketcher/Gui/CommandConstraints.cpp Diff File

Issue History

Date Modified Username Field Change
2017-04-01 17:29 normandc New Issue
2017-04-01 17:30 normandc Additional Information Updated View Revisions
2017-04-02 10:17 kkremitzki Note Added: 0008748
2017-04-02 10:17 kkremitzki Tag Attached: #lowhangingfruit
2017-04-26 02:51 Kunda1 Assigned To => abdullah
2017-04-26 02:51 Kunda1 Status new => assigned
2017-04-26 02:54 Kunda1 Note Added: 0008768
2017-04-26 16:49 abdullah Note Added: 0008779
2017-04-28 02:06 Kunda1 Note Added: 0008787
2017-04-30 16:58 abdullah Note Added: 0008834
2017-05-02 10:41 wmayer Status assigned => closed
2017-05-02 10:41 wmayer Resolution open => fixed
2017-05-02 10:41 wmayer Fixed in Version => 0.17
2017-05-02 10:41 wmayer Note Added: 0008846
2017-05-02 10:46 Kunda1 Note Added: 0008847
2017-05-02 10:47 Kunda1 Changeset attached => FreeCAD master cfc2d86c
2017-05-02 10:47 Kunda1 Changeset attached => FreeCAD master 40c6d4be
2017-05-02 10:48 Kunda1 Changeset attached => FreeCAD master 7bee2c54
2017-05-02 10:48 Kunda1 Tag Detached: #lowhangingfruit