View Issue Details

IDProjectCategoryView StatusLast Update
0002992PartDesignBugpublic2017-08-28 19:42
ReporterrabbitAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSDebian JessieOS Version64 Bit
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002992: SEGV related to chamfering?
DescriptionWhen changing anything in an existing sketch in the attached file, a SEGV results.

This seems to affect existing sketches in body "main" prior to the "Chamfer002" step, but it does not affect other bodies or sketches after "Chamfer002", which I why I assume it's related to chamfering.
Steps To Reproduce
  1. Open an existing sketch in body "main" (e.g. Sketch025).
  2. Add something, e.g. a construction line
  3. SEGV
Additional InformationConsole output:


Program received signal SIGSEGV, Segmentation fault.
#0  /lib/x86_64-linux-gnu/libc.so.6(+0x350e0) [0x7f29901b40e0]
#1  0x7f292d18fbd3 in ChFi3d_IsInFront(TopOpeBRepDS_DataStructure&, opencascade::handle<ChFiDS_Stripe> 
const&, opencascade::handle<ChFiDS_Stripe> const&, int, int, int, int, double&, double&, 
TopoDS_Face&, bool&, int&, int&, bool&, TopoDS_Vertex const&, bool, bool) from 
./lib/x86_64-linux-gnu/libTKFillet.so.7+0x103
# 2  0x7f292d21c2cd in ChFi3d_ChBuilder::PerformThreeCorner(int) from ./lib/x86_64-linux-gnu/libTKFillet.so.7+0x4dcd

# 3  0x7f292d1812eb in ChFi3d_Builder::PerformFilletOnVertex(int) from ./lib/x86_64-linux-gnu/libTKFillet.so.7+0x50b

# 4  0x7f292d1818e1 in ChFi3d_Builder::Compute() from ./lib/x86_64-linux-gnu/libTKFillet.so.7+0x511

# 5  0x7f292d3024f0 in BRepFilletAPI_MakeChamfer::Build() from ./lib/x86_64-linux-gnu/libTKFillet.so.7+0x20

# 6  0x7f292d5f0ed3 in PartDesign::Chamfer::execute() from /tmp/.mount_6OryoB/usr/lib/freecad-daily/lib/_PartDesign.so+0x753

# 7  0x7f29925c3c65 in App::DocumentObject::recompute() from ././/lib/freecad-daily/lib/libFreeCADApp.so+0x15

# 8  0x7f29191cd24f in Part::Feature::recompute() from ././/lib/freecad-daily/lib/Part.so+0xf
# 9  0x7f2992593fec in App::Document::_recomputeFeature(App::DocumentObject*) from ././/lib/freecad-daily/lib/libFreeCADApp.so+0x9c

# 10  0x7f2992599e72 in App::Document::recompute() from ././/lib/freecad-daily/lib/libFreeCADApp.so+0x362

# 11  0x7f29925e6704 in App::DocumentPy::recompute(_object*) from ././/lib/freecad-daily/lib/libFreeCADApp.so+0x34

# 12  0x7f29925e6807 in App::DocumentPy::staticCallback_recompute(_object*, _object*) from ././/lib/freecad-daily/lib/libFreeCADApp.so+0x27

# 13  ./lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x4bd4) [0x7f2991d570d4]
# 14  ./lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x80d) [0x7f2991d5917d]
# 15  ./lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCode+0x32) [0x7f2991d59462]
# 16  ./lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyRun_StringFlags+0x79) [0x7f2991c9dac9]
# 17  0x7f29921f9354 in Base::InterpreterSingleton::runString(char const*) from ././/lib/freecad-daily/lib/libFreeCADBase.so+0x54

# 18  0x7f2992ca6cf2 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x132

# 19  0x7f2992ca74e6 in Gui::Command::updateActive() from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x26

# 20  0x7f2915cc3de1 in DrawSketchHandlerLine::releaseButton(Base::Vector2d) from /tmp/.mount_6OryoB/usr/lib/freecad-daily/lib/SketcherGui.so+0x151

# 21  0x7f2915d55219 in SketcherGui::ViewProviderSketch::mouseButtonPressed(int, bool, SbVec2s const&, 
Gui::View3DInventorViewer const*) from /tmp/.mount_6OryoB/usr/lib/freecad-daily/lib/SketcherGui.so+0x249

# 22  0x7f2992e98f7a in Gui::ViewProvider::eventCallback(void*, SoEventCallback*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0xca

# 23  0x7f298faf395b in SoEventCallback::handleEvent(SoHandleEventAction*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0xbb

# 24  0x7f298fb07c0c in SoNode::handleEventS(SoAction*, SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x4c

# 25  0x7f298f8cdc04 in SoAction::traverse(SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x54
# 26  0x7f298fa1d294 in SoChildList::traverse(SoAction*, int, int) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x174

# 27  0x7f298fafd66f in SoGroup::doAction(SoAction*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x3f

# 28  0x7f298fb1a6d7 in SoSeparator::doAction(SoAction*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x27

# 29  0x7f2992ddfae7 in Gui::SoFCUnifiedSelection::handleEvent(SoHandleEventAction*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x87

# 30  0x7f298fb07c0c in SoNode::handleEventS(SoAction*, SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x4c

# 31  0x7f298f8cdc04 in SoAction::traverse(SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x54
# 32  0x7f298fa1d294 in SoChildList::traverse(SoAction*, int, int) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x174

# 33  0x7f298fafd66f in SoGroup::doAction(SoAction*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x3f

# 34  0x7f298fb1a6d7 in SoSeparator::doAction(SoAction*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x27

# 35  0x7f298fb07c0c in SoNode::handleEventS(SoAction*, SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x4c

# 36  0x7f298f8cdc04 in SoAction::traverse(SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x54
# 37  0x7f298f8d81aa in SoHandleEventAction::beginTraversal(SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x7a

# 38  0x7f298f8ce7d2 in SoAction::apply(SoNode*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0xd2
# 39  0x7f298fa3b0a9 in SoEventManager::actuallyProcessEvent(SoEvent const*) from ./lib/x86_64-linux-gnu/libCoin.so.80+0x69

# 40  0x7f2992e4f5de in SIM::Coin3D::Quarter::QuarterWidget::processSoEvent(SoEvent const*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x1e

# 41  0x7f2992e4e633 in SIM::Coin3D::Quarter::SoQTQuarterAdaptor::processSoEvent(SoEvent const*) from 
././/lib/freecad-daily/lib/libFreeCADGui.so+0x43
# 42  0x7f2992e78709 in Gui::View3DInventorViewer::processSoEventBase(SoEvent const*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x9

# 43  0x7f2992e5dc7c in Gui::CADNavigationStyle::processSoEvent(SoEvent const*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x3fc

# 44  0x7f2992e5aac2 in Gui::NavigationStyle::processEvent(SoEvent const*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x62

# 45  0x7f2992e786d7 in Gui::View3DInventorViewer::processSoEvent(SoEvent const*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x77

# 46  0x7f2992e4bcac in SIM::Coin3D::Quarter::EventFilter::eventFilter(QObject*, QEvent*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x16c

# 47  0x7f2990bd4646 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) from 
./lib/x86_64-linux-gnu/libQtCore.so.4+0x86
# 48  0x7f2991108e0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from ./lib/x86_64-linux-gnu/libQtGui.so.4+0x6c

# 49  0x7f299110f5dd in QApplication::notify(QObject*, QEvent*) from ./lib/x86_64-linux-gnu/libQtGui.so.4+0x3ad

# 50  0x7f2992c87fb1 in Gui::GUIApplication::notify(QObject*, QEvent*) from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x41

# 51  0x7f2990bd44dd in QCoreApplication::notifyInternal(QObject*, QEvent*) from ./lib/x86_64-linux-gnu/libQtCore.so.4+0x6d

# 52  0x7f299110ed93 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, 
QWidget**, QPointer<QWidget>&, bool) from ./lib/x86_64-linux-gnu/libQtGui.so.4+0x153
# 53  ./lib/x86_64-linux-gnu/libQtGui.so.4(+0x2449cb) [0x7f29911839cb]
# 54  0x7f2991183269 in QApplication::x11ProcessEvent(_XEvent*) from ./lib/x86_64-linux-gnu/libQtGui.so.4+0x1559

# 55  ./lib/x86_64-linux-gnu/libQtGui.so.4(+0x26bb02) [0x7f29911aab02]
# 56  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x24d) [0x7f2989a18c5d]
# 57  /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x49f48) [0x7f2989a18f48]
# 58  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f2989a18ffc]
# 59  0x7f2990c017a1 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) 
from ./lib/x86_64-linux-gnu/libQtCore.so.4+0x71
# 60  ./lib/x86_64-linux-gnu/libQtGui.so.4(+0x26bbb6) [0x7f29911aabb6]
# 61  0x7f2990bd30af in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from ./lib/x86_64-linux-gnu/libQtCore.so.4+0x2f

# 62  0x7f2990bd33a5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from ./lib/x86_64-linux-gnu/libQtCore.so.4+0x175

# 63  0x7f2990bd8b79 in QCoreApplication::exec() from ./lib/x86_64-linux-gnu/libQtCore.so.4+0x89
# 64  0x7f2992c45e91 in Gui::Application::runApplication() from ././/lib/freecad-daily/lib/libFreeCADGui.so+0x1371

# 65  FreeCAD-0.17.git201703220057.glibc2.17-x86_64.AppImage(main+0x6ad) [0x4032cd]
# 66  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f29901a0b45]
# 67  FreeCAD-0.17.git201703220057.glibc2.17-x86_64.AppImage() [0x4040f2]


Freecad AppImage from github:


OS: Debian GNU/Linux 8.7 (jessie)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10600 (Git)
Build type: None
Branch: master
Hash: 4d9169faf778e9716fc647fb3fcf46462b5d99a4
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
TagsNo tags attached.

Activities

rabbit

2017-03-30 08:01

reporter  

master-0.17.fcstd (936,588 bytes)

Kunda1

2017-03-30 15:53

administrator   ~0008739

Please start a thread on the forum and then bidirectionally link thread <=> ticket to generate more conversation about this issue. Thank you.

rabbit

2017-03-30 17:46

reporter   ~0008740

OK, here it is.

normandc

2017-04-02 03:34

manager   ~0008746

Confirmed on

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10665 (Git)
Build type: None
Branch: master
Hash: 47847513a85ff6615774ef628230f79e37471daf
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0

normandc

2017-04-02 03:36

manager   ~0008747

No crash on an older 0.17-dev version compiled with OCC 6.8.0.

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10473 (Git)
Build type: Unknown
Branch: master
Hash: 78b986a2657b7de79b6e350a2535dc0fbfe3f1cf
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-04-28 14:52

administrator   ~0008802

@NormandC does that mean this maybe an upstream OCC bug?

abdullah

2017-05-24 22:46

manager   ~0009127

@kunda1

I cannot reproduce:

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11122 (Git)
Build type: Debug
Branch: occ_extra_info
Hash: a0da4b16a8768779ce32480046d3c0109595d5e5
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0 (TBB)

Kunda1

2017-05-24 22:48

administrator   ~0009128

Resolving. But needs more testers before closing.

Kunda1

2017-08-28 19:42

administrator   ~0010036

Closing

Issue History

Date Modified Username Field Change
2017-03-30 08:01 rabbit New Issue
2017-03-30 08:01 rabbit File Added: master-0.17.fcstd
2017-03-30 13:09 Kunda1 Assigned To => Kunda1
2017-03-30 13:09 Kunda1 Status new => assigned
2017-03-30 15:53 Kunda1 Assigned To Kunda1 =>
2017-03-30 15:53 Kunda1 Status assigned => feedback
2017-03-30 15:53 Kunda1 Note Added: 0008739
2017-03-30 17:46 rabbit Note Added: 0008740
2017-03-30 17:46 rabbit Status feedback => new
2017-04-02 03:34 normandc Note Added: 0008746
2017-04-02 03:36 normandc Note Added: 0008747
2017-04-28 14:52 Kunda1 Status new => confirmed
2017-04-28 14:52 Kunda1 Note Added: 0008802
2017-05-24 22:46 abdullah Note Added: 0009127
2017-05-24 22:48 Kunda1 Status confirmed => resolved
2017-05-24 22:48 Kunda1 Resolution open => fixed
2017-05-24 22:48 Kunda1 Fixed in Version => 0.17
2017-05-24 22:48 Kunda1 Note Added: 0009128
2017-08-28 19:42 Kunda1 Status resolved => closed
2017-08-28 19:42 Kunda1 Note Added: 0010036