View Issue Details

IDProjectCategoryView StatusLast Update
0002965FEM[FreeCAD] Featurepublic2017-06-08 12:37
ReporterHoWil Assigned Toberndhahnebach  
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0002965: FEM - GUI, removing warning when creating a mesh from boolean fragments
DescriptionThere is a warning :!: displayed when meshing boolean-fragments basically saying that problems can arise when meshing a component.
The thing is, that a boolean-fragments should by definition make no problems for meshing. There can't be any intersecting solids and therfore gmsh should always produce a nice result.
I use boolean fragments together with gmsh mesh in Fc on a daily basis and always clicking this warning is annoying :?.
I see three possibilities for implementing something against the above :
* inserting a check on the content of the boolean-fragments compound before the warning is risen
* insert a setting in the preferences to deselect for such warnings
* insert a checkbox at the warning to never show it again

This is for sure of low priority, since until now not so many use fc to create multi-body meshes. But I am sure that the numbers will rise at the latest when Openfoam and elmer are integrated.
TagsFEM, Mesh
FreeCAD Information

Relationships

related to 0003021 closedm42kus FEM - solver Elmer (Ongoing) 

Activities

HoWil

2017-03-14 13:14

developer   ~0008628

The related discussion in the forum is https://forum.freecadweb.org/viewtopic.php?f=18&t=21314
Bernd asked to assign this task to him, looks like I do not have the rights to do that.

berndhahnebach

2017-05-28 21:49

developer   ~0009179

Last edited: 2017-05-28 21:50

View 3 revisions

we really need to get rid of this popup. The BooleanFragments generate very cool topology for meshing, but they are Compounds ( https://forum.freecadweb.org/viewtopic.php?f=8&t=22531&start=20#p175909 and following). Furthermore there need to be some changes at the warnings in GMSH mesh class.

I will go for that hopefully soon. Bernd

berndhahnebach

2017-06-08 04:48

developer   ~0009311

fixed with

https://github.com/FreeCAD/FreeCAD/commit/20b4865061426ff7119a01e9f08ec936612c14d4

Issue History

Date Modified Username Field Change
2017-03-14 12:59 HoWil New Issue
2017-03-14 12:59 HoWil Tag Attached: FEM
2017-03-14 12:59 HoWil Tag Attached: Mesh
2017-03-14 13:14 HoWil Note Added: 0008628
2017-03-14 14:48 berndhahnebach Assigned To => berndhahnebach
2017-03-14 14:48 berndhahnebach Status new => assigned
2017-03-14 14:48 berndhahnebach Description Updated View Revisions
2017-03-14 14:48 berndhahnebach Description Updated View Revisions
2017-03-14 19:18 Kunda1 Note View State: 0008628: public
2017-05-08 06:07 Kunda1 Relationship added related to 0003021
2017-05-28 21:49 berndhahnebach Note Added: 0009179
2017-05-28 21:50 berndhahnebach Note Edited: 0009179 View Revisions
2017-05-28 21:50 berndhahnebach Note Edited: 0009179 View Revisions
2017-05-28 21:55 berndhahnebach Summary removing warning when creating a mesh from boolean fragments => FEM - GUI, removing warning when creating a mesh from boolean fragments
2017-06-08 04:48 berndhahnebach Note Added: 0009311
2017-06-08 04:50 berndhahnebach Status assigned => closed
2017-06-08 04:50 berndhahnebach Resolution open => fixed
2017-06-08 12:37 Kunda1 Fixed in Version => 0.17