View Issue Details

IDProjectCategoryView StatusLast Update
0002921SketcherBugpublic2017-02-24 18:55
Reporterjnxd Assigned Towmayer  
PrioritylowSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002921: Anomalous behavior while panning/zooming etc.
DescriptionTake a look at the attached files, and for each one double-click on the sketch and pan and zoom around. I could see that the size of the text of the dimension scales up/down when panning horizontally or zooming in the case of pan_anomaly_test2.fcstd and pan_anomaly_test3.fcstd, but not in pan_anomaly_test1.fcstd.
Steps To ReproduceHow I made the files:

  • anomaly_test1.fcstd: Open file -> switch to sketcher WB and new sketch -> make sketch with some measurement constraint -> close sketch.
  • pan_anomaly_test2.fcstd: Open file -> make body -> copy sketch from pan_anomaly_test1.fcstd at document level -> delete body.
  • pan_anomaly_test1.fcstd: Open file -> copy sketch from pan_anomaly_test1.fcstd at document level.
Additional InformationDiscussed here initially.
TagsPart Design

Relationships

parent of 0002922 closedwmayer SoDatumLabel changes text size when panning the 3d view horizontally 

Activities

jnxd

2017-02-23 22:00

updater   ~0008414

Forgot to attach the files. Also, the bug seems to be there in 0.15 too!

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4671 (Git)
Branch: releases/FreeCAD-0-15
Hash: 244b3aef360841646cbfe80a1b225c8b39c8380c
Python version: 2.7.11
Qt version: 4.8.7
Coin version: 4.0.0a

pan_anomaly_test1.fcstd (3,324 bytes)
pan_anomaly_test2.fcstd (3,310 bytes)
pan_anomaly_test3.fcstd (3,278 bytes)

wmayer

2017-02-24 18:54

administrator   ~0008421

Fix committed to master branch.

Related Changesets

FreeCAD: master 10191e90

2017-02-24 18:54:16

wmayer

Details Diff
fixes 0002921, fixes 0002922 Affected Issues
0002921, 0002922
mod - src/Mod/Sketcher/Gui/SoDatumLabel.cpp Diff File

Issue History

Date Modified Username Field Change
2017-02-23 21:40 jnxd New Issue
2017-02-23 21:40 jnxd Tag Attached: Part Design
2017-02-23 22:00 jnxd File Added: pan_anomaly_test1.fcstd
2017-02-23 22:00 jnxd File Added: pan_anomaly_test2.fcstd
2017-02-23 22:00 jnxd File Added: pan_anomaly_test3.fcstd
2017-02-23 22:00 jnxd Note Added: 0008414
2017-02-24 16:30 wmayer Relationship added parent of 0002922
2017-02-24 18:54 wmayer Changeset attached => FreeCAD master 10191e90
2017-02-24 18:54 wmayer Note Added: 0008421
2017-02-24 18:54 wmayer Assigned To => wmayer
2017-02-24 18:54 wmayer Status new => closed
2017-02-24 18:54 wmayer Resolution open => fixed
2017-02-24 18:55 wmayer Fixed in Version => 0.17