View Issue Details

IDProjectCategoryView StatusLast Update
0002899FreeCADBugpublic2017-07-11 20:10
ReporterfabianhuAssigned Tokkremitzki 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformX86OSUbuntuOS Version16.04
Product Version0.17 
Target VersionFixed in Version 
Summary0002899: Sketcher and Part design - decimal point values ignored
DescriptionEffect happens with german locale. (decimal separator ',')
Decimal point values can not be entered in sketcher and part design.
The values are truncated to the full numbers.
e.g. 40,3 -> 40
If you enter 40.3 -> 403 (kind of expected)
Steps To ReproduceSwitch to german locale (decimal separator ',')
Enter a number as sketch length or extrusion length.
Additional InformationOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10064 (Git)
Build type: None
Branch: master
Hash: d7ed8c4383f394f64dd9314eefa00efae02fb32f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Tagslocale, units

Relationships

duplicate of 0002891 closedwmayer Sketcher Sketching impossible, Type.Error Exception 

Activities

Kunda1

2017-02-13 14:26

manager   ~0008283

Last edited: 2017-02-13 16:23

View 2 revisions

This looks like a duplicate. Please check the locale tag to verify that it is. If not please open a forum thread to discuss it.

Link: https://freecadweb.org/tracker/search.php?tag_string=locale

fabianhu

2017-02-14 23:10

reporter   ~0008297

Just installed newest version on another machine. Works perfectly like before.
There were some locale related changes undone between this versions...

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10064 (Git)
Build type: None
Branch: master
Hash: d7ed8c4383f394f64dd9314eefa00efae02fb32f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-02-15 02:34

manager   ~0008300

Last edited: 2017-02-15 12:23

View 2 revisions

I think this is the locale issue resolved in 0002891 by @wmayer
Resolving as duplicate

Issue History

Date Modified Username Field Change
2017-02-11 21:14 fabianhu New Issue
2017-02-13 14:24 Kunda1 Tag Attached: units
2017-02-13 14:24 Kunda1 Tag Attached: locale
2017-02-13 14:26 Kunda1 Note Added: 0008283
2017-02-13 14:26 Kunda1 Status new => feedback
2017-02-13 16:23 Kunda1 Note Edited: 0008283 View Revisions
2017-02-14 23:07 fabianhu Tag Attached: #tobeclosed
2017-02-14 23:10 fabianhu Note Added: 0008297
2017-02-14 23:10 fabianhu Status feedback => new
2017-02-15 02:34 Kunda1 Note Added: 0008300
2017-02-15 02:34 Kunda1 Relationship added duplicate of 0002891
2017-02-15 02:34 Kunda1 Status new => resolved
2017-02-15 02:34 Kunda1 Resolution open => duplicate
2017-02-15 02:34 Kunda1 Assigned To => Kunda1
2017-02-15 02:35 Kunda1 Assigned To Kunda1 =>
2017-02-15 12:23 Kunda1 Note Edited: 0008300 View Revisions
2017-03-10 20:30 kkremitzki Assigned To => kkremitzki
2017-03-10 20:30 kkremitzki Status resolved => closed
2017-07-11 20:10 Kunda1 Tag Detached: #tobeclosed