View Issue Details

IDProjectCategoryView StatusLast Update
0002885Path[FreeCAD] Bugpublic2018-01-22 18:42
Reportermlampert Assigned Tomlampert  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002885: Dressups drop feedrate from commands
DescriptionDressups holding tags and dogbone do not insert feed rates for each command - which are needed by the post processor to generate valid g-code.

The reason this has gone undetected for a while is because feed rates are sticky in g-code. As long as the first operation isn't dressed up it will set the feed rates which will get applied until changed.
Steps To ReproduceCreate a Job for a part.
As its only operation create a Contour operation
Dressup the op with holding tags
Inspect generated g-code and check for F parameters in each command.
Additional Informationhttps://forum.freecadweb.org/viewtopic.php?f=15&t=20439
TagsNo tags attached.
FreeCAD Information

Activities

Kunda1

2017-02-02 22:26

administrator   ~0008183

Added forum link to the ticket

wmayer

2018-01-22 18:42

administrator   ~0010815

https://github.com/FreeCAD/FreeCAD/commit/23f88c5d85c2128a116a362920a9faba09e03325

Issue History

Date Modified Username Field Change
2017-02-02 22:06 mlampert New Issue
2017-02-02 22:06 mlampert Status new => assigned
2017-02-02 22:06 mlampert Assigned To => mlampert
2017-02-02 22:26 Kunda1 Note Added: 0008183
2017-02-02 22:26 Kunda1 Additional Information Updated View Revisions
2018-01-22 18:42 wmayer Status assigned => closed
2018-01-22 18:42 wmayer Resolution open => fixed
2018-01-22 18:42 wmayer Fixed in Version => 0.17
2018-01-22 18:42 wmayer Note Added: 0010815