View Issue Details

IDProjectCategoryView StatusLast Update
0002870Path[FreeCAD] Bugpublic2017-01-28 21:18
Reportermlampert Assigned Tomlampert  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002870: Path unit tests broken by questionable include and not being executed as part of '0'
DescriptionPathDressupHoldingTags imports DraftGui to get access to the todo class - which was used during development. However, DraftGui cannot be included for the unit tests because ti mandates a running Gui.

Also there seems to be a '0' unit test target which is run as part of the CI build. This target currently does not include the Path unit tests. In other words, the unit tests currently can't be used to prevent regressions because they are not executed regularly (continuously).
TagsNo tags attached.
FreeCAD Information

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master 175d1776

2017-01-28 21:15:51

wwmayer


Committer: GitHub Details Diff
Merge pull request 0000467 from mlampert/path-unit-test-fixes

Path: Path unit test fixes issue 0002870
Affected Issues
0002870
mod - src/Mod/Path/CMakeLists.txt Diff File
mod - src/Mod/Path/PathScripts/PathDressupHoldingTags.py Diff File
mod - src/Mod/Path/PathTests/PathTestUtils.py Diff File
mod - src/Mod/Path/PathTests/TestPathDressupHoldingTags.py Diff File
mod - src/Mod/Path/TestPathApp.py Diff File
mod - src/Mod/Test/TestApp.py Diff File

Issue History

Date Modified Username Field Change
2017-01-22 04:00 mlampert New Issue
2017-01-22 04:00 mlampert Status new => assigned
2017-01-22 04:00 mlampert Assigned To => mlampert
2017-01-28 21:16 Changeset attached => FreeCAD Master master 175d1776
2017-01-28 21:18 wmayer Status assigned => closed
2017-01-28 21:18 wmayer Resolution open => fixed
2017-01-28 21:18 wmayer Fixed in Version => 0.17