View Issue Details

IDProjectCategoryView StatusLast Update
0002868FreeCAD[All Projects] Generalpublic2019-01-16 16:36
ReporterblaceyAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformAllOSMac OS XOS Version10.11.x
Product Version0.17 
Target Version0.19Fixed in Version0.19 
Summary0002868: Port QtWebKit to QtWebEngine
DescriptionAs of Qt 5.6, QtWebKit is deprecated in favor of QtWebEngine. The QtWebKit source is still available but not included in any Qt 5.6 or later distros.

Currently the Web Mod depends upon QtWebKit causing exceptions upon launch when built without QtWebKit

Qt 5.7 is already out and the plan is for FreeCAD 0.17 to release on Qt 5.x so we need to find a path to remove the dependency on QtWebKit.
Additional Informationhttps://forum.freecadweb.org/viewtopic.php?f=10&t=20105&e=1&view=unread#unread
http://blog.qt.io/blog/2015/12/18/qt-5-6-beta-released/
https://wiki.qt.io/Porting_from_QtWebKit_to_QtWebEngine
TagsQt, Qt5

Relationships

duplicate of 0003774 closed Support of QtWebEngine as alternative to QtWebkit 
related to 0001401 closedwmayer Problem w/ MDI windows on OSX (AKA transition from QGLWidget to QOpenGLWidget ) 
related to 0002953 closed Icons not rendered on New doc 
child of 0002986 closedwmayer Port from Qt4 to Qt5 (Ongoing) 

Activities

wmayer

2018-04-22 19:02

administrator   ~0011179

According to https://wiki.debian.org/Qt4WebKitRemoval the Qt4 webkit package has been removed but a Qt5 webkit is at least maintained until Qt6 will appear. It's true that Qt webkit is not part of the Qt base any more but it's still available as an add-on.

Under Ubuntu 18.04 building the Web module works without changing a single line and at runtime it works flawlessly.

According to https://stackoverflow.com/questions/29055475/qwebview-or-qwebengineview at some point in the future we must move to Qt webengine but there is no reason to do this now unless we need the latest and greatest HTML5 features.
Since our start page doesn't need these features we can stay with webkit for now. IMO, we can do the move when we fully drop Qt4 support.

wmayer

2018-04-24 13:34

administrator   ~0011189

Last edited: 2018-04-24 13:34

View 2 revisions

Here is an initial port to webengine: https://github.com/wwmayer/FreeCAD/commits/webengine
However, the QtWebEngineWidgets is a very heavy package and thus we should think about using something more lightweight. Maybe Qt's QML or QtQuick is an option.

Kunda1

2019-01-14 20:52

administrator   ~0012433

Changed summary to QtWebEngine

wmayer

2019-01-16 13:53

administrator   ~0012438

Last edited: 2019-01-16 16:33

View 2 revisions

A merge request has been created with 0003774 to offer QtWebEngine as an alternative. This will be done for v0.19, then.

Issue History

Date Modified Username Field Change
2017-01-21 20:34 blacey New Issue
2017-01-21 21:05 Kunda1 Tag Attached: Qt
2017-01-21 21:05 Kunda1 Tag Attached: Qt5
2017-01-21 21:06 Kunda1 Relationship added related to 0001401
2017-01-22 14:26 Kunda1 Summary Port to QtWebKit to QtWebKitEngine => Port QtWebKit to QtWebKitEngine
2017-03-09 23:43 Kunda1 Relationship added related to 0002953
2017-03-27 17:26 Kunda1 Relationship added child of 0002986
2018-04-22 19:02 wmayer Note Added: 0011179
2018-04-24 13:34 wmayer Note Added: 0011189
2018-04-24 13:34 wmayer Note Edited: 0011189 View Revisions
2019-01-14 20:52 Kunda1 Summary Port QtWebKit to QtWebKitEngine => Port QtWebKit to QtWebEngine
2019-01-14 20:52 Kunda1 Note Added: 0012433
2019-01-14 20:52 Kunda1 Target Version => 0.19
2019-01-16 13:19 Kunda1 Relationship added related to 0003774
2019-01-16 13:21 Kunda1 Description Updated View Revisions
2019-01-16 13:53 wmayer Status new => closed
2019-01-16 13:53 wmayer Resolution open => fixed
2019-01-16 13:53 wmayer Fixed in Version => 0.19
2019-01-16 13:53 wmayer Note Added: 0012438
2019-01-16 16:33 Kunda1 Note Edited: 0012438 View Revisions
2019-01-16 16:36 Kunda1 Relationship replaced duplicate of 0003774