View Issue Details

IDProjectCategoryView StatusLast Update
0002864Path[FreeCAD] Patchpublic2017-02-19 03:09
ReporterproteusAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSopenSUSEOS VersionLeap 42.1 / 42.2
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0002864: PathHelix x10 issue on "Step in Z" inputfield and "Step in Radius"
DescriptionAfter i open the PathHelix UI in the input field "Step in Z" the value is multiplied by 10. In the input filed "Step in Radius" is always the diameter from the tooltable. In the attachment is a patch for this issue. With this patch now the previous_value is propper working.
Steps To Reproducedouble klick on PathHelix icon on the left side of the tree.
Additional InformationOS: "openSUSE Leap 42.1 (x86_64)"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9661 (Git)
Build type: Release
Branch: master
Hash: 5b5189a8d69378e4216062bab6932978ce303be7
Python version: 2.7.12
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.9.1.oce-0.18-dev
TagsNo tags attached.

Activities

proteus

2017-01-16 22:20

reporter  

0003-Add-PathHelix_Fix_for_x10_input_field_issue_017.patch (1,016 bytes)
From a33f71c8b3a76374db2c4c8e731ab9fe3630f7c2 Mon, 16 Jan 2017 12:36:57 +0100
From: Michael Kruschinsky <mk@mysmk.de>
Date: Mon, 16 Jan 2017 12:06:38 +0100
Subject: [PATCH] 0003-Add-PathHelix_Fix_for_x10_input_field_issue_017


Signed-off-by: Michael Kruschinsky <mk@mysmk.de>
diff --git a/src/Mod/Path/PathScripts/PathHelix.py b/src/Mod/Path/PathScripts/PathHelix.py
index db8ecd7..38ac501 100644
--- a/src/Mod/Path/PathScripts/PathHelix.py
+++ b/src/Mod/Path/PathScripts/PathHelix.py
@@ -587,7 +587,9 @@
                 label = QtGui.QLabel(labelstring)
                 label.setToolTip(self.obj.getDocumentationOfProperty(property))
 
-            widget.setText(str(getattr(self.obj, property)))
+            # Fix for x10: replace dot with comma.
+            # it's the first fix, i think there was a better one, but it works.
+            widget.setText(str(getattr(self.obj, property)).replace('.', ','))
             widget.setToolTip(self.obj.getDocumentationOfProperty(property))
 
             if max:

Kunda1

2017-01-28 13:10

manager   ~0008053

Posted to the forum https://forum.freecadweb.org/viewtopic.php?f=10&t=20311
@proteus In the future you could use github to submit a Pull Request. It's pretty easy and helps the devs since TravisCI runs on all submitted PRs which include running unit tests.

Kunda1

2017-02-02 13:11

manager   ~0008169

@proteus according to chrisb this is not the correct way to fix this issue.
See https://forum.freecadweb.org/viewtopic.php?f=10&t=20311#p156599
> This error had been in the Path Workbench as well, see https://forum.freecadweb.org/viewtopic.php?f=10&t=18833&start=10 . The fix with replacing ',' should not be used (it was my first try as well), instead use the unit stuff as is done in PathPocket.py.
Since this error occurs here and there in different modules (it has been reported in FEM and ARCH) it should be fixed in the same way or better: The usage of input fields should be everywhere the same in FreeCAD.

Kunda1

2017-02-13 21:57

manager   ~0008288

Last edited: 2017-02-13 21:59

View 4 revisions

Fix committed in: c:FreeCAD:8a4952044eb592c0f8ad4f60889d63e9ed69ee7b
by @lorenz in https://forum.freecadweb.org/viewtopic.php?f=10&t=20311#p159730

Kunda1

2017-02-14 13:46

manager   ~0008291

Last edited: 2017-02-14 13:49

View 2 revisions

A confusion occurred since this commit has not been accepted yet. Still a PR
FreeCAD Pull Request 523
https://github.com/FreeCAD/FreeCAD/pull/523

Kunda1

2017-02-17 23:12

manager   ~0008340

Last edited: 2017-02-19 03:09

View 4 revisions

PR committed that supposedly fixes this ticket.
c:FreeCAD:837f2ea:
c:FreeCAD:e38d0ad:

Kunda1

2017-02-17 23:14

manager   ~0008341

No way to attribute fix to lorenz
Also source-integration mantis plugin not working correctly.

Kunda1

2017-02-18 12:09

manager   ~0008345

@proteus please test the latest master to verify fix. Thanks

proteus

2017-02-18 13:22

reporter   ~0008348

Hello Kunda1,

i have dissabled my patch and test it on the master branch from 017 version. It's working, you can closed this bug.
How can i change my loginname from proteus to proteusmk? I need proteusmk while my loginname on github is proteusmk.

regards michael

Kunda1

2017-02-18 13:24

manager   ~0008349

@proteus thanks for responding. mention something on IRC or gitter.im/FreeCAD/FreeCAD
Closing ticket.

Issue History

Date Modified Username Field Change
2017-01-16 22:20 proteus New Issue
2017-01-16 22:20 proteus File Added: 0003-Add-PathHelix_Fix_for_x10_input_field_issue_017.patch
2017-01-17 00:16 Kunda1 Category Bug => Patch
2017-01-28 13:10 Kunda1 Note Added: 0008053
2017-02-02 13:11 Kunda1 Note Added: 0008169
2017-02-02 13:11 Kunda1 Status new => feedback
2017-02-13 21:57 Kunda1 Note Added: 0008288
2017-02-13 21:58 Kunda1 Note Edited: 0008288 View Revisions
2017-02-13 21:59 Kunda1 Note Edited: 0008288 View Revisions
2017-02-13 21:59 Kunda1 Note Edited: 0008288 View Revisions
2017-02-13 22:00 Kunda1 Status feedback => resolved
2017-02-13 22:00 Kunda1 Fixed in Version => 0.17
2017-02-13 22:00 Kunda1 Resolution open => fixed
2017-02-13 22:00 Kunda1 Assigned To => Kunda1
2017-02-13 22:00 Kunda1 Assigned To Kunda1 =>
2017-02-14 13:46 Kunda1 Note Added: 0008291
2017-02-14 13:46 Kunda1 Status resolved => acknowledged
2017-02-14 13:49 Kunda1 Note Edited: 0008291 View Revisions
2017-02-14 13:49 Kunda1 Resolution fixed => open
2017-02-14 13:49 Kunda1 Fixed in Version 0.17 =>
2017-02-17 23:12 Kunda1 Note Added: 0008340
2017-02-17 23:14 Kunda1 Status acknowledged => resolved
2017-02-17 23:14 Kunda1 Resolution open => fixed
2017-02-17 23:14 Kunda1 Fixed in Version => 0.17
2017-02-17 23:14 Kunda1 Note Added: 0008341
2017-02-18 12:09 Kunda1 Note Added: 0008345
2017-02-18 13:22 proteus Status resolved => feedback
2017-02-18 13:22 proteus Resolution fixed => reopened
2017-02-18 13:22 proteus Note Added: 0008348
2017-02-18 13:24 Kunda1 Assigned To => wmayer
2017-02-18 13:24 Kunda1 Status feedback => closed
2017-02-18 13:24 Kunda1 Resolution reopened => fixed
2017-02-18 13:24 Kunda1 Note Added: 0008349
2017-02-19 03:08 kkremitzki Note Edited: 0008340 View Revisions
2017-02-19 03:08 kkremitzki Note Edited: 0008340 View Revisions
2017-02-19 03:09 kkremitzki Note Edited: 0008340 View Revisions