View Issue Details

IDProjectCategoryView StatusLast Update
0002861Path[FreeCAD] Bugpublic2017-05-09 15:10
ReportermlampertAssigned Tosliptonic 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002861: Contour operation produces wrong path if top face has pockets on an edge
DescriptionTried with round and square pockets that go through half the part and both produce wrong contour paths. Interestingly round pockets only if more than half the circle is part of the pocket.

In the screenshot, the difference between the two round pockets is that one has it's centre outside the part, whereas the other has it right on the edge. Moving the centre farther into the part also produces the wrong path.

The behaviour is reproduceable regardless if the shape is constructed through Part or PartDesign.
TagsNo tags attached.

Activities

mlampert

2017-01-15 17:57

developer  

contour.png (2,777 bytes)
contour.png (2,777 bytes)

sliptonic

2017-01-16 00:43

developer  

snapshot-1.png (83,112 bytes)
snapshot-1.png (83,112 bytes)

sliptonic

2017-01-16 00:43

developer  

snapshot-2.png (71,755 bytes)
snapshot-2.png (71,755 bytes)

sliptonic

2017-01-16 00:45

developer   ~0007803

I ran a git bisect and it looks like the bug appeared with this commit:

commit 6e7c4915a3a11c32b1c82c128b6b6c0d8799c744
Author: wmayer <wmayer@users.sourceforge.net>
Date: Sun Jan 15 16:34:14 2017 +0100

    fixes 0002858: Vector2d Equality Incorrect

Before it, the TechDraw.findShapeOutline() function produced a wire like snapshot-1 afterward, it looks like snapshot-2

sliptonic

2017-05-09 15:10

developer   ~0008927

Issues was resolved some time ago but not closed in mantis.

Issue History

Date Modified Username Field Change
2017-01-15 17:57 mlampert New Issue
2017-01-15 17:57 mlampert File Added: contour.png
2017-01-16 00:43 sliptonic File Added: snapshot-1.png
2017-01-16 00:43 sliptonic File Added: snapshot-2.png
2017-01-16 00:45 sliptonic Note Added: 0007803
2017-05-09 15:10 sliptonic Assigned To => sliptonic
2017-05-09 15:10 sliptonic Status new => closed
2017-05-09 15:10 sliptonic Resolution open => fixed
2017-05-09 15:10 sliptonic Fixed in Version => 0.17
2017-05-09 15:10 sliptonic Note Added: 0008927