View Issue Details

IDProjectCategoryView StatusLast Update
0002857PartDesignBugpublic2018-01-13 16:32
ReportertilleAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformKernel Linux 3.19.0-32-generic xOSLinux MintOS Version17.3 Rosa 64-bit
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0002857: Placement incorrect in exported files
DescriptionI tried to export an assembly consisting of several bodys, each one containing a box. each body was placed using the Placement option. When exporting (tested with .step and .brep imported in FreeCAD and Salome), the boxes all still were in their initial position, except for rotated boxes. So, Placement x/y/z doesn't work, but rotation about axes worked.
Steps To Reproducego to Part Design --> create new body --> create additive primitive --> change placement of primitive --> export primitive as .step/.brep file --> import file in FreeCAD --> check placement of imported file.
Additional InformationOS: Linux Mint 17.3 Rosa
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9613 (Git)
Build type: None
Branch: master
Hash: 0c34f1b749fbb116058caa54754961c6dcb4f92a
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Relationships

related to 0002642 closed Can't open saved file (undiscovered bug/s from PDN?) 

Activities

tille

2017-01-14 10:32

reporter  

viga.fcstd (29,147 bytes)

Kunda1

2017-01-19 12:17

manager   ~0007872

Last edited: 2017-01-19 12:31

View 2 revisions

re-jigged summary for better comprehension
Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20048

nemesis

2017-01-23 20:52

reporter   ~0007923

Last edited: 2017-01-23 20:52

View 2 revisions

Confirmed on :

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9787 (Git)
Build type: Release
Branch: (detached from 417f074)
Hash: 417f074aff779e4c3c3fce7ef755dc3a38691d63
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 7.0.0


terminal output :

Can't find Origin for "Body001"

this for each Body

Kunda1

2017-05-11 12:38

manager   ~0008954

Is this related to 0002642 ?

wmayer

2018-01-13 16:32

administrator   ~0010755

Has been fixed in recent months. FYI, for export you must select the body and not the primitive because the body stores the placement information.

Issue History

Date Modified Username Field Change
2017-01-14 10:32 tille New Issue
2017-01-14 10:32 tille File Added: viga.fcstd
2017-01-19 12:17 Kunda1 Note Added: 0007872
2017-01-19 12:17 Kunda1 Summary Placement doesn't in exported files => Placement incorrect in exported files
2017-01-19 12:31 Kunda1 Note Edited: 0007872 View Revisions
2017-01-23 20:52 nemesis Note Added: 0007923
2017-01-23 20:52 nemesis Note Edited: 0007923 View Revisions
2017-05-11 12:37 Kunda1 Relationship added related to 0002642
2017-05-11 12:38 Kunda1 Note Added: 0008954
2017-09-15 20:23 wmayer Target Version => 0.17
2018-01-13 16:32 wmayer Status new => closed
2018-01-13 16:32 wmayer Resolution open => fixed
2018-01-13 16:32 wmayer Fixed in Version => 0.17
2018-01-13 16:32 wmayer Note Added: 0010755