View Issue Details

IDProjectCategoryView StatusLast Update
0002851Path[FreeCAD] Bugpublic2017-05-02 22:02
Reportersliptonic Assigned Tosliptonic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002851: adding additional objects to drilling operation results in duplicate entries.
DescriptionAfter selecting edges to drill and creating the operation, it presents a dialog if other circular edges of the same diameter were found. If the user agrees to drill these as well, the same dialog appears again and duplicate edges are added to the list.
Steps To Reproduce select 3 holes, click on drill it says "found multiple .... drill them all?" I click OK, I get the same dialog again click OK and I end up with 5 edges in Base
TagsNo tags attached.
FreeCAD Information

Relationships

has duplicate 0002852 closedmlampert Selecting multiple holes for a drilling operation, and adding all of them results in some holes being added to Base twice. 

Activities

sliptonic

2017-01-14 05:29

developer   ~0007752

In part, this happens because a circular hole has two circular edges of the same diameter. When the drilling searches for other holes, it finds both and adds them as candidate locations. It should de-dupe based on center locations but doesn't.

I think the drilling operation needs a lot of work and a better UI. For example,

perhaps instead of saving the object subelements in the base geometry, we should save the XY coordinates of the drilling location.

Instead of having the user select drilling locations, we should prepopulate the list with all drillable locations and diameters and let the user enable/disable.

If the user starts by selecting a circle, we could add all locations to the list and present a choice dialog to:
  1) enabled only the selected 'hole'
  2) enable all other 'holes' of the same diameter.
  3) enable all drillable holes in the part.

Kunda1

2017-05-02 22:02

administrator   ~0008868

Closing manually since mantis source integration didn't get triggered by FreeCAD Pull Request 628

Issue History

Date Modified Username Field Change
2017-01-13 22:45 sliptonic New Issue
2017-01-13 22:45 sliptonic Status new => assigned
2017-01-13 22:45 sliptonic Assigned To => sliptonic
2017-01-14 01:14 mlampert Relationship added has duplicate 0002852
2017-01-14 05:29 sliptonic Note Added: 0007752
2017-05-02 22:02 Kunda1 Status assigned => closed
2017-05-02 22:02 Kunda1 Resolution open => fixed
2017-05-02 22:02 Kunda1 Fixed in Version => 0.17
2017-05-02 22:02 Kunda1 Note Added: 0008868