View Issue Details

IDProjectCategoryView StatusLast Update
0002832FreeCADFeaturepublic2017-08-13 15:32
Reporterruchg Assigned Toyorik  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSFedora 25OS Version4.8.15-300
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0002832: Dimension polish
DescriptionI believe that more dimension properties need to be made available in Edit --> Preferences --> Draft --> Text and Dimensions.

For example the Property window View tab lists Decimals, however it is not available in the Preferences window. This forces the user to select multiple dimensions and set decimals en mass to the desired value. If the setting was available in Preferences this would not be necessary. The user may one day be working on a house drawing in millimeters and doesn't need decimals and on the next day working on a clock drawing where he needs all the precision he can get.

Another property might be Line Width that may change from day to day as the user moves from house drawings to watch parts.

It would also be easier if the two lists used the same names for the same things.

I've included a line by line listing for illustration.
Preferences View Tab Dimension Properties
                                        Base
                                 Y Display Mode
                             Y Visibility
                                       Draft
     Y Y Arrow Size
     Y Arrow style Y Arrow Type
    No Y Decimals
    Y Y Ext Lines
    No Y Flip Arrows
    Y Font family Y Font Name
    Y Y Font Size
    No Y Line Color
    No Y Line Width
    No Y Override
    No Y Pattern
    No Y Pattern Size
    Y Y Show Unit
    No Y Text Position
    Y Y Text Spacing
Additional InformationI've enclosed a spreadsheet table which better shows the table above.
TagsNo tags attached.
FreeCAD Information

Activities

ruchg

2017-01-07 15:45

reporter  

FreeCADdimensioningPolish.ods (Attachment missing)

yorik

2017-01-07 16:17

administrator   ~0007568

The dimension decimals are there already, in the Draft General tab. Indeed that setting should be moved to the dimensions tab.

The line width takes the general line width setting of Draft, that applies to all Draft objects. It is settable in the preferences as well as on the toolbar...

Kunda1

2017-05-02 11:13

administrator   ~0008849

@yorik looks like OPs spreadsheet is missing. Is it needed for implementing this feature?

yorik

2017-05-02 23:23

administrator   ~0008873

@Kunda1 I don't think so, I think it contained the same thing that is on the OP

Actually the things I wanted to do in this issue are done, from my point of view...

I didn't understand well the problem with 'Line Width' and the rest, @ruchg ?

Kunda1

2017-05-27 19:19

administrator   ~0009171

@ruchg please respond

Kunda1

2017-07-03 21:13

administrator   ~0009658

Resolving since op hasn't responded

Kunda1

2017-08-13 15:32

administrator   ~0009906

Closing

Related Changesets

FreeCAD: master 162c74c2

2017-01-07 17:20:58

yorik

Details Diff
Draft: Moved dimension decimals preference setting to the dimension preferences tab - issue 0002832 Affected Issues
0002832
mod - src/Mod/Draft/Resources/ui/preferences-draft.ui Diff File
mod - src/Mod/Draft/Resources/ui/preferences-drafttexts.ui Diff File

Issue History

Date Modified Username Field Change
2017-01-07 15:45 ruchg New Issue
2017-01-07 15:45 ruchg File Added: FreeCADdimensioningPolish.ods
2017-01-07 16:17 yorik Note Added: 0007568
2017-01-07 16:17 yorik Assigned To => yorik
2017-01-07 16:17 yorik Status new => assigned
2017-01-07 16:21 yorik Changeset attached => FreeCAD Master master 162c74c2
2017-05-02 11:13 Kunda1 Note Added: 0008849
2017-05-02 23:23 yorik Note Added: 0008873
2017-05-27 19:19 Kunda1 Status assigned => feedback
2017-05-27 19:19 Kunda1 Note Added: 0009171
2017-07-03 21:13 Kunda1 Status feedback => resolved
2017-07-03 21:13 Kunda1 Resolution open => fixed
2017-07-03 21:13 Kunda1 Note Added: 0009658
2017-07-03 21:14 Kunda1 Fixed in Version => 0.17
2017-08-13 15:32 Kunda1 Status resolved => closed
2017-08-13 15:32 Kunda1 Note Added: 0009906