View Issue Details

IDProjectCategoryView StatusLast Update
0002831FreeCADBugpublic2017-01-08 22:34
ReportergfindernigAssigned Tonormandc 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.16 
Target VersionFixed in Version 
Summary0002831: Fusion fails with error message
DescriptionWhen fusing a cube to a fusion of 2 cubes operation fails and resulting object shows error message "Resulting shape is invalid"
Steps To ReproduceSee attached protocol "Action_Protocol.txt" and source file "BugReport_20170107.FCStd"
Additional InformationAll files in attached "Debug.zip"
TagsNo tags attached.

Activities

gfindernig

2017-01-07 13:24

reporter  

Debug.zip (Attachment missing)

normandc

2017-01-08 22:31

manager   ~0007574

This is a common problem with Boolean operations caused by FreeCAD's geometric modeling kernel (OCC). It's bad practice to apply Booleans on objects that share many coplanar and coincident faces.

This issue is explained here, it's written for OpenSCAD but relevant to FreeCAD: http://www.iheartrobotics.com/2010/01/openscad-tip-manifold-space-and-time.html

As explained in the "READ THIS BEFORE REPORTING" link, you should have posted first in the FreeCAD forum to avoid filling the bug tracker with known and unfixable issues that already have easy workarounds.

normandc

2017-01-08 22:34

manager   ~0007575

This issue has been mentioned repeated times on the forum, it's due to the OCC kernel over which the FreeCAD team has no control. It's easily worked around by slightly changing the modelling method and/or the order of Booleans. The forum is the place to ask for such matters.

Issue History

Date Modified Username Field Change
2017-01-07 13:24 gfindernig New Issue
2017-01-07 13:24 gfindernig File Added: Debug.zip
2017-01-08 22:31 normandc Note Added: 0007574
2017-01-08 22:34 normandc Note Added: 0007575
2017-01-08 22:34 normandc Status new => closed
2017-01-08 22:34 normandc Assigned To => normandc
2017-01-08 22:34 normandc Resolution open => won't fix