View Issue Details

IDProjectCategoryView StatusLast Update
0002815SketcherBugpublic2017-05-01 00:29
ReporterSternaAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformMacbook Pro late 2011OSOS XOS Version10.11.6
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002815: Default shortcut (shift + d) for "Constrain distance" has conflict
DescriptionOne of the most useful constraint in the sketcher is the Distance constraint. The keyboard shortcut for this is (and has been for a while) shift+D. Recently, the function "Docked" has been assigned to the same shortfuct, which conflicts, and hinders the function. Please change the default shortcut for Docked to something else.
Steps To ReproduceOpen Sketcher
Draw a line
Press shift+D (nothing happens, since windows are docked be default)
Additional InformationWorkaround: Using the Customize menu, re-assign the keyboard shortcut for Docked (under Standard view) to something else.
Tagskeyboard, shortcuts

Activities

Kunda1

2017-01-28 20:58

manager   ~0008065

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20323

Kunda1

2017-02-04 10:33

manager   ~0008209

@Sterna in the future please first post this as a forum thread feature request before opening a ticket. This is a guideline stated in http://forum.freecadweb.org/viewtopic.php?f=3&t=5236
To make your argument heard and discussed please participate in the forum thread I opened for you ^
Thanks.

Kunda1

2017-04-29 11:33

manager   ~0008820

@yorik is this still the case in 0.17 ? If so this FR sounds reasonable.

Kunda1

2017-05-01 00:29

manager   ~0008837

Per the forum thread this is a non-issue in current 0.17 master.

Issue History

Date Modified Username Field Change
2016-12-06 15:14 Sterna New Issue
2017-01-28 20:58 Kunda1 Note Added: 0008065
2017-02-04 10:25 Kunda1 Tag Attached: keyboard
2017-02-04 10:25 Kunda1 Tag Attached: shortcuts
2017-02-04 10:28 Kunda1 Summary Default shortcut for "Constrain distance" has conflict => Default shortcut (shift + d) for "Constrain distance" has conflict
2017-02-04 10:33 Kunda1 Note Added: 0008209
2017-02-04 10:33 Kunda1 Status new => feedback
2017-04-29 11:33 Kunda1 Note Added: 0008820
2017-05-01 00:29 Kunda1 Status feedback => closed
2017-05-01 00:29 Kunda1 Resolution open => fixed
2017-05-01 00:29 Kunda1 Fixed in Version => 0.17
2017-05-01 00:29 Kunda1 Note Added: 0008837