View Issue Details

IDProjectCategoryView StatusLast Update
0002793FreeCADFeaturepublic2019-01-17 14:39
Reporterherrdeh Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.16 
Target Version0.18Fixed in Version0.18 
Summary0002793: "tube" as basic solid
DescriptionI hardly ever use the "torus" or the "prism" but spend lots of time with creating all kinds of tubes out of two cylinders.
Wouldnt it be nice to have a "tube" basic solid? - Inner, outer diameter, height - and we are done.

TagsNo tags attached.

Activities

hinckel

2016-11-26 15:16

reporter   ~0007489

This is a nice feature to have!

normandc

2016-11-26 17:23

manager   ~0007490

But that is the problem : a tube is *not* a primitive. The Part workbench primitives are not intended to create complex shapes, only geometric primitives.

A tube could only be added to a special purpose workbench, but definitely not to the Make Primitives utility.

BTW using a sketch with two concentric circles and making a PartDesign Pad you can create a tube, and you can resize its dimensions quite quickly. Or with some python scripting you can create your own parametric objects.

wmayer

2019-01-17 14:39

administrator   ~0012451

https://github.com/FreeCAD/FreeCAD/commit/552ed9eab2aa615f8e9744608236aa48893327dd

Issue History

Date Modified Username Field Change
2016-11-25 08:11 herrdeh New Issue
2016-11-26 15:16 hinckel Note Added: 0007489
2016-11-26 17:23 normandc Note Added: 0007490
2017-09-15 10:37 wmayer Target Version => 0.17
2017-11-21 16:12 Kunda1 Target Version 0.17 => 0.18
2019-01-17 14:39 wmayer Assigned To => wmayer
2019-01-17 14:39 wmayer Status new => closed
2019-01-17 14:39 wmayer Resolution open => fixed
2019-01-17 14:39 wmayer Fixed in Version => 0.18
2019-01-17 14:39 wmayer Note Added: 0012451