View Issue Details

IDProjectCategoryView StatusLast Update
0002757PartDesignBugpublic2016-11-06 10:23
ReporteramineAssigned Towmayer 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform64 bitOSubuntuOS Version14.04
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002757: sketch editing not visible when it is in a part
DescriptionHello,
the sketch can not be edited when the "body" is created inside a "part".
I can use the sketcher tools to draw but without seeing any lines, and after I close the sketch, I'll find the drawn sketch.
Steps To ReproduceStart Freecad 0.17
create a part
create a body
create a sketch
I can't see anything, only the background (no grid)
when I close the sketch I'll find the lines I've drawn.
Additional InformationOS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.8819 (Git)
Build type: None
Branch: master
Hash: 195ea429e696377980b4edbf4a4affdb1f46abaa
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Activities

amine

2016-11-04 22:12

reporter  

sketch in part not visible.fcstd (8,040 bytes)

wmayer

2016-11-06 09:48

administrator   ~0007443

This is caused by commit d9376eb4. The Part container's Inventor root node has two children where the second one is a switch. The switch's whichChild attribute is set to -1 (everything is hidden) instead of 0 (its first child is shown).

wmayer

2016-11-06 10:23

administrator   ~0007444

It turned out to be a bug in DepGraphTools.isContainer because it didn't consider the Part group as a container.

Related Changesets

FreeCAD: master 60e6ad2e

2016-11-06 11:21:11

wmayer

Details Diff
issue 0002757: sketch editing not visible when it is in a part Affected Issues
0002757
mod - src/Mod/Show/DepGraphTools.py Diff File

Issue History

Date Modified Username Field Change
2016-11-04 22:12 amine New Issue
2016-11-04 22:12 amine File Added: sketch in part not visible.fcstd
2016-11-05 16:36 wmayer Status new => confirmed
2016-11-06 09:48 wmayer Note Added: 0007443
2016-11-06 10:21 wmayer Changeset attached => FreeCAD Master master 60e6ad2e
2016-11-06 10:23 wmayer Note Added: 0007444
2016-11-06 10:23 wmayer Status confirmed => closed
2016-11-06 10:23 wmayer Assigned To => wmayer
2016-11-06 10:23 wmayer Resolution open => fixed
2016-11-06 10:23 wmayer Fixed in Version => 0.17