View Issue Details

IDProjectCategoryView StatusLast Update
0002734FreeCADFeaturepublic2017-04-28 19:30
ReporterMajorTeslaAssigned To 
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformOSWindlwsOS Version10
Product Version0.16 
Target VersionFixed in Version 
Summary0002734: Partial sketch grid
DescriptionThe Sketch grid does not always extend to the limits of the object face. This is awkward when using the snap-to-grid feature.
Steps To Reproduce1. Start FreeCAD
2. Select New empty document.
3. Select or confirm 'Part Design' WB
4. Select 'Create a new sketch'.
5. Select XY plane then OK
6. Draw large rectangle (nearly fills the screen).
7. Close Tasks.
8. Select Pad
9. Close Tasks
10. Select the face of object facing you.
11. Select 'Make a new sketch'.
12. Draw a small circle near the origin of the sketching plane (near the middle of the object).
Most of the grid will vanish and a small portion of it will surround the small circle you have just drawn! The ability to draw another circle, at the edge of the object, that snaps to the grid can not now be easily achieved.
Tagsgrid

Relationships

duplicate of 0001271 confirmed Sketcher Allow User to Toggle Automatic Grid Sizeing in Sketcher On and Off 
related to 0001658 closed Sketcher Sketcher: Grid vanishes when drawing horizontal polyline on horizontal sketcher line 

Activities

MajorTesla

2016-10-12 17:28

reporter  

FreeCAD-vanishing-grid.jpg (Attachment missing)

normandc

2016-10-15 19:18

manager   ~0007366

I am not seeing this behaviour. The grid size remains intact after creating the circle. But once the sketch is closed and reopened, then the grid is re-sized as in your screen capture. This has always been the behaviour in the Sketcher, the grid is re-sized according to the geometry.

As a workaround you could draw a large rectangle to make the grid bigger. But FYI the grid and snapping to it is only a convenience utility that you should not heavily rely on. You still need to constrain the geometry. In the commercial parametric CAD packages I know of, none of them provides a grid like in the sketcher. And I've never missed it...

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6703 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 2ce5c8d2e3020d05005ed71f710e09e9aa561f40
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-03-21 12:48

administrator   ~0008678

per wmayer this is a dupe of 0001271 and NormandC has offered a workaround and explanation.
Resolving ticket.

Issue History

Date Modified Username Field Change
2016-10-12 17:28 MajorTesla New Issue
2016-10-12 17:28 MajorTesla File Added: FreeCAD-vanishing-grid.jpg
2016-10-15 19:18 normandc Note Added: 0007366
2016-10-19 17:10 wmayer Relationship added duplicate of 0001271
2017-03-21 12:46 Kunda1 Tag Attached: grid
2017-03-21 12:48 Kunda1 Status new => resolved
2017-03-21 12:48 Kunda1 Resolution open => duplicate
2017-03-21 12:48 Kunda1 Note Added: 0008678
2017-03-21 12:51 Kunda1 Relationship added related to 0001658
2017-04-28 19:30 Kunda1 Status resolved => closed