View Issue Details

IDProjectCategoryView StatusLast Update
0002697PartDesignBugpublic2016-12-28 16:34
Reporteralpha6Assigned Towmayer 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Version 
Target VersionFixed in Version0.17 
Summary0002697: Can't create a pad or a pocket on the detail
DescriptionHello.

I can't create a pad or a pocket on the detail.
If I try to create one, the detail disappears from the screen and after I press "OK" button I see the window with text "Error".
And the same way I get a message "Document::recompute: The graph must be a DAG." on my console.

I use FreeCad daily build from ubuntu ppa.
The FreeCad version is:

OS: Ubuntu 16.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.8405 (Git)
Build type: None
Branch: master
Hash: 05a25967bd756405a688526f4b63c5fad6e71378
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Steps To Reproduce1. Open the attached document
2. Create sketch on any surface
3. Draw circle or hexagon
3.a. If I draw a rectangle - FreeCad falling down with error message:
freecad-daily: SoGroup.cpp:292: virtual SoNode* SoGroup::getChild(int) const: Assertion `(index >= 0) && (index < this->getNumChildren())' failed.
Aborted (core dumped)

4. Create pad or pocket from the sketch
5. The detail disappear from screen
Additional InformationIf I remove the Pocket006 and his sketch and create it again - everything work fine.
TagsNo tags attached.

Activities

alpha6

2016-09-14 21:42

reporter  

hotend_holder_v2.fcstd (85,658 bytes)

ulrich1a

2016-10-16 14:46

reporter   ~0007385

The following forum post describes, how to produce a document with such an error: http://forum.freecadweb.org/viewtopic.php?f=3&t=17995#p141473

Ulric

wmayer

2016-12-28 16:17

administrator   ~0007552

With the following Python snippet the circular dependency can be fixed:

pad=App.ActiveDocument.Pad
pad.UpToFace=None

wmayer

2016-12-28 16:19

administrator   ~0007553

The attached change set (commit 70040818) fixes the reason to create the circular dependency.

wmayer

2016-12-28 16:34

administrator   ~0007554

The crash is not reproducible (any more). But the non DAG issue is fixed.

Related Changesets

FreeCAD: master 70040818

2016-12-28 17:05:20

wmayer

Details Diff
avoid to create a circular dependency when modifying an existing pad or pocket operation Affected Issues
0002697
mod - src/Mod/PartDesign/Gui/TaskFeatureParameters.cpp Diff File
mod - src/Mod/PartDesign/Gui/TaskSketchBasedParameters.cpp Diff File
mod - src/Mod/PartDesign/Gui/ViewProvider.cpp Diff File

Issue History

Date Modified Username Field Change
2016-09-14 21:42 alpha6 New Issue
2016-09-14 21:42 alpha6 File Added: hotend_holder_v2.fcstd
2016-10-16 14:46 ulrich1a Note Added: 0007385
2016-12-28 16:17 wmayer Note Added: 0007552
2016-12-28 16:18 wmayer Changeset attached => FreeCAD Master master 70040818
2016-12-28 16:19 wmayer Note Added: 0007553
2016-12-28 16:34 wmayer Note Added: 0007554
2016-12-28 16:34 wmayer Status new => closed
2016-12-28 16:34 wmayer Assigned To => wmayer
2016-12-28 16:34 wmayer Resolution open => fixed
2016-12-28 16:34 wmayer Fixed in Version => 0.17