View Issue Details

IDProjectCategoryView StatusLast Update
0002690DraftBugpublic2017-02-20 00:33
ReporterbgoodrAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformUbuntu LinuxOSUbuntu 16.04.1 LTSOS VersionUbuntu 16.04.1
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002690: Regression: Mouse snapping to vertices is broken in 0.17.8353
DescriptionMouse snapping to vertices does not work on version 0.17, but does work in version 0.16.

Stable 0.16 build I used that works is:

OS: Ubuntu 16.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6703 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 2ce5c8d2e3020d05005ed71f710e09e9aa561f40
Python version: 2.7.11+
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Unstable 0.17 build that does not work is:

OS: Ubuntu 16.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.8353 (Git)
Build type: None
Branch: master
Hash: 04aa24ec00bcd05442b1b345757175a4459fc553
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Steps To Reproduce1. Start freecad-daily
2. Create a new design using Part design
3. Switch to Draft workbench
4. Add a rectangle somewhere (not on grid)
5. Set workplane to that rectangle
6. Start a line object (L I)
7. Move mouse cursor over to a vertex of the added rectangle
8. Mouse should change to show the vertex image but does not. It does on 0.16 stable build.

See annotated screenshot: http://i.imgur.com/7SpIZhC.png

Tagssnap

Activities

yorik

2016-09-04 18:56

administrator   ~0007303

I cannot reproduce this problem, for me everything works normally...

yorik

2016-09-11 19:43

administrator   ~0007314

Are you sure the "snap to working plane" option is not enabled? That might cause your actual snap point to be quite far from your object...

bgoodr

2016-09-25 17:49

reporter   ~0007332

I apologize for the late reply.

I tested this again using today's freecad and I can reproduce it easily. I confirmed that I am definitely on the workplane of the rectangle object and the mouse cursor does not change as I expect it to when the mouse is moved close to a corner vertex on the rectangle I just added. I have 0.16 installed and it does change.

Below is the part of the installation log indicating the version of 0.17 I am using of freecad-daily:

Selecting previously unselected package freecad-daily.
Preparing to unpack .../freecad-daily_0.17~alpha1+git201609212031~ubuntu16.04.1_amd64.deb ...
Unpacking freecad-daily (0.17~alpha1+git201609212031~ubuntu16.04.1) ...
Selecting previously unselected package freecad-daily-doc.
Preparing to unpack .../freecad-daily-doc_0.17~alpha1+git201609212031~ubuntu16.04.1_all.deb ...
Unpacking freecad-daily-doc (0.17~alpha1+git201609212031~ubuntu16.04.1) ...


What else can I do to demonstrate this bug?

bgoodr

2016-09-25 17:52

reporter   ~0007333

Another thing I noticed on version 0.17: Moving the cursor to the midpoint of an edge of the rectangle should cause the mouse cursor to change to something that indicates that the mouse is on the midpoint, because I have snapping to midpoint selected. But it does not. So it seems that maybe one or more snapping behaviors are not working on this build for some reason.

bgoodr

2016-09-25 17:56

reporter   ~0007334

This is the 0.17 version I'm using for my recent posts above:

OS: Ubuntu 16.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.8469 (Git)
Build type: None
Branch: master
Hash: 40c79f18e4d63c86fa865c43f0276ee1cff00abb
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-01-31 18:48

administrator  

7SpIZhC.png (189,399 bytes)
7SpIZhC.png (189,399 bytes)

Kunda1

2017-01-31 18:50

administrator   ~0008136

@bgoodr please create a thread in the forum to generate further discussion about the issue. Thx.

bgoodr

2017-02-12 07:26

reporter   ~0008275

@Kunda1 I have posted it into the forum at https://forum.freecadweb.org/viewtopic.php?f=3&t=20627#p159459

Kunda1

2017-02-15 19:34

administrator   ~0008313

@bgoodr you have a response from @normandc in https://forum.freecadweb.org/viewtopic.php?f=3&t=20627#p159548

Kunda1

2017-02-18 12:13

administrator   ~0008346

@bgoodr
> bgoodr wrote:
> Mouse snapping to vertices is broken in 0.17.8353
in September you updated to 0.17.8469

This bug report is from last year. Can you confirm that your freecad-daily package is up to date. The latest development revision number is over 10 000.

bgoodr

2017-02-20 00:02

reporter   ~0008376

As reported just now on the forum thread, I have verified this is now working with this build:

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10150 (Git)
Build type: None
Branch: master
Hash: 978978f7dd1814083d7b9c9fc4267dba25f58a80
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-02-20 00:33

administrator   ~0008377

Thanks for the follow up.
Closing ticket as fixed

Issue History

Date Modified Username Field Change
2016-09-04 17:34 bgoodr New Issue
2016-09-04 18:56 yorik Note Added: 0007303
2016-09-11 19:43 yorik Note Added: 0007314
2016-09-25 17:49 bgoodr Note Added: 0007332
2016-09-25 17:52 bgoodr Note Added: 0007333
2016-09-25 17:56 bgoodr Note Added: 0007334
2017-01-31 18:48 Kunda1 File Added: 7SpIZhC.png
2017-01-31 18:49 Kunda1 Product Version => 0.17
2017-01-31 18:50 Kunda1 Note Added: 0008136
2017-01-31 18:50 Kunda1 Status new => feedback
2017-01-31 18:50 Kunda1 Tag Attached: snap
2017-02-12 07:26 bgoodr Note Added: 0008275
2017-02-12 07:26 bgoodr Status feedback => new
2017-02-15 19:32 Kunda1 Summary Mouse snapping to vertices is broken in 0.17.8353 => Regression: Mouse snapping to vertices is broken in 0.17.8353
2017-02-15 19:34 Kunda1 Note Added: 0008313
2017-02-15 19:34 Kunda1 Status new => feedback
2017-02-18 12:13 Kunda1 Note Added: 0008346
2017-02-20 00:02 bgoodr Note Added: 0008376
2017-02-20 00:02 bgoodr Status feedback => new
2017-02-20 00:33 Kunda1 Status new => closed
2017-02-20 00:33 Kunda1 Resolution open => fixed
2017-02-20 00:33 Kunda1 Fixed in Version => 0.17
2017-02-20 00:33 Kunda1 Note Added: 0008377