View Issue Details

IDProjectCategoryView StatusLast Update
0002653FreeCADFeaturepublic2018-08-26 18:05
ReportertrampasAssigned ToKunda1 
PriorityhighSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Product Version0.16 
Target VersionFixed in Version 
Summary0002653: Sketch constraints and lines
DescriptionThe snaps to line ends is so hard to make happen I often place lines that are not connected. It takes forever to find the one that is .01 microns off.
See 0003085

What would be nice is to have lines change colors if they are fully constrained, or maybe have points change colors if they are matched.
See 0000704:0009406

Additionally it would be nice to have the CTRL key during line operation increase the snap active area such that it is easy to match points.
See 0003086

Also it would be nice to have a line chain option where next starting point of line is last placed point of previous line, for example place a line while holding down a key...
See 0003087
TagsNo tags attached.

Relationships

duplicate of 0003087 closedchrisb FreeCAD have a line chain option where next starting point of line is last placed point of previous line 
duplicate of 0003086 new Sketcher CTRL key during line operation increase the snap active area such that it is easy to match points 
duplicate of 0003085 closed FreeCAD The snaps-to-line-ends is so hard to make happen 

Activities

normandc

2016-08-07 17:04

manager   ~0007256

This report is poorly made because it includes 4 totally different feature requests.

Did you know that you can use the Polyline tool instead of the line tool? I seldom use the Line tool.

>What would be nice is to have lines change colors if they are fully constrained
There are 3 existing feature requests for this. But this is hard to implement. 0000704

Kunda1

2017-01-13 00:07

administrator   ~0007697

What should we do with this ticket? Split it in to separate feature requests ?

Kunda1

2017-06-16 12:29

administrator   ~0009407

@trampas please open a forum ticket next time to discuss each Feature Request with the community. Many decisions happen on the forum and feedback will be offered. Also Shen opening a ticket please limit one issue per ticket. It makes it easier to Triage. I've split your ticket in the meantime. Thanks for your comprehension.

Issue History

Date Modified Username Field Change
2016-08-04 11:48 trampas New Issue
2016-08-07 17:04 normandc Note Added: 0007256
2017-01-13 00:07 Kunda1 Note Added: 0007697
2017-01-13 00:07 Kunda1 Tag Attached: split ticket
2017-06-16 11:55 Kunda1 Description Updated View Revisions
2017-06-16 12:16 Kunda1 Description Updated View Revisions
2017-06-16 12:21 Kunda1 Relationship added duplicate of 0003087
2017-06-16 12:22 Kunda1 Relationship added duplicate of 0003086
2017-06-16 12:23 Kunda1 Relationship added duplicate of 0003085
2017-06-16 12:29 Kunda1 Assigned To => Kunda1
2017-06-16 12:29 Kunda1 Status new => closed
2017-06-16 12:29 Kunda1 Resolution open => duplicate
2017-06-16 12:29 Kunda1 Note Added: 0009407
2017-07-04 19:54 Kunda1 Description Updated View Revisions
2018-08-26 18:05 Kunda1 Tag Detached: split ticket