View Issue Details

IDProjectCategoryView StatusLast Update
0002638FreeCADBugpublic2016-07-24 09:30
ReporteroneiragAssigned To 
PrioritylowSeveritytrivialReproducibilityhave not tried
Status closedResolutionfixed 
PlatformWindowsOSWindows 10OS Version64 bit
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0002638: Windows installer doesn't create the macro folder
DescriptionThe installer doesn't create the C:/Users/<name_of_windows_user>/AppData/Roaming/FreeCAD/Macro folder during the installation process, therefore user macro fails to run (e.g. the dxf importer, that has to be manually installed when importing a dwg file, even if the program lets you do it automatically it does not work due to the inexistence of the mentioned folder)
Steps To Reproduceremove C:/Users/<name_of_windows_user>/AppData/Roaming/FreeCAD folder and its contents and reinstall freecad.
TagsNo tags attached.

Activities

wmayer

2016-07-24 09:29

administrator   ~0007214

It's not up to the installer to do this because it runs in the context of an administrator and thus doesn't even know for which user it has to create the directory.

Instead it's up to the application to do it on start-up.

Related Changesets

FreeCAD: master f00a0b1a

2016-07-24 11:25:21

wmayer

Details Diff
issue 0002638: Windows installer doesn't create the macro folder Affected Issues
0002638
mod - src/App/Application.cpp Diff File

Issue History

Date Modified Username Field Change
2016-07-24 04:39 oneirag New Issue
2016-07-24 09:26 wmayer Changeset attached => FreeCAD Master master f00a0b1a
2016-07-24 09:29 wmayer Note Added: 0007214
2016-07-24 09:29 wmayer Status new => closed
2016-07-24 09:30 wmayer Resolution open => fixed
2016-07-24 09:30 wmayer Fixed in Version => 0.17