View Issue Details

IDProjectCategoryView StatusLast Update
0002637FreeCADBugpublic2017-07-11 20:08
ReporterleopolettiAssigned Tokkremitzki 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform64 bitOSLinux MintOS Version17.3
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0002637: Inconsistent 3D after removing operation (pocket or boolean operation)
DescriptionOS: Linux Mint 17.3 Rosa
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6703 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 2ce5c8d2e3020d05005ed71f710e09e9aa561f40
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Inconsistent surface after different operation when remove function have been made tangently.
Steps To ReproduceI create a sketch for a tooth and want to create a belt support by create a pocket and then a linear pattern of this tooth in partdesign module.
The linearpattern is defined to put perfectly side by side the tooth.
The result give inconsistent surface.
The same problem has been reproduce by using the array function after creating a pad with the tooth sketch.
Additional InformationThe problem disappear with FreeCad Daily 0.17 after updating a parameter:
OS: Linux Mint 17.3 Rosa
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7989 (Git)
Build type: None
Branch: master
Hash: 8051d32adc646a1580d43a38253fd5eddb3932e6
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Relationships

duplicate of 0002028 closedkkremitzki PartDesign Polar Pattern feature leaves faces missing 

Activities

leopoletti

2016-07-23 13:34

reporter  

Y_BeltHolder_0.16.fcstd (Attachment missing)

leopoletti

2016-07-26 18:04

reporter  

WithFreeCad0.16.png (Attachment missing)

leopoletti

2016-07-26 18:04

reporter  

WithFreecad0.17.png (Attachment missing)

normandc

2016-07-31 22:01

manager   ~0007234

Last edited: 2016-07-31 22:02

View 2 revisions

This is a common occurrence with transformation features that share faces. There have been many, many bug reports similar to it. Many of them are listed in 0002028 in this comment: http://www.freecadweb.org/tracker/view.php?id=2028#c6377

leopoletti

2016-08-01 08:03

reporter   ~0007236

Yes. I did not see those bug report. Nevertheless my point with this report is to propose to patch the 0.16 with the same solution for 0.17 since in this in development this pb has been fixed.

Kunda1

2017-01-28 11:58

administrator   ~0008045

Reminder sent to: wmayer, yorik

OP asks:
> Nevertheless my point with this report is to propose to patch the 0.16 with the same solution for 0.17 since in this in development this pb has been fixed.

Issue History

Date Modified Username Field Change
2016-07-23 13:34 leopoletti New Issue
2016-07-23 13:34 leopoletti File Added: Y_BeltHolder_0.16.fcstd
2016-07-26 18:04 leopoletti File Added: WithFreeCad0.16.png
2016-07-26 18:04 leopoletti File Added: WithFreecad0.17.png
2016-07-31 22:01 normandc Note Added: 0007234
2016-07-31 22:02 normandc Note Edited: 0007234 View Revisions
2016-08-01 08:03 leopoletti Note Added: 0007236
2017-01-28 11:48 Kunda1 Tag Attached: #pending
2017-01-28 11:48 Kunda1 Tag Attached: #tobeclosed
2017-01-28 11:58 Kunda1 Note Added: 0008045
2017-01-28 11:59 Kunda1 Tag Detached: #tobeclosed
2017-01-28 11:59 Kunda1 Relationship added duplicate of 0002028
2017-03-22 01:07 kkremitzki Assigned To => kkremitzki
2017-03-22 01:07 kkremitzki Status new => closed
2017-03-22 01:07 kkremitzki Resolution open => fixed
2017-03-22 01:07 kkremitzki Fixed in Version => 0.17
2017-07-11 20:08 Kunda1 Tag Detached: #pending