View Issue Details

IDProjectCategoryView StatusLast Update
0002582PartDesignBugpublic2016-10-15 15:43
ReporterGeneFC Assigned Towmayer  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows 64OS Version7
Product Version 
Target VersionFixed in Version0.17 
Summary0002582: Polar array axis selectiion fails
DescriptionPart Design, FC version 0.17.7709 (Git)

Unable to select alternate axis for polar pattern. "Select reference..." appears to work, with no error messages, but the new selected axis is not used. Log trace appears to show correct selection, but when PolarPattern task is exited with the "OK" button the selection reverts back to the basic body axis.

Reported on forum:

http://forum.freecadweb.org/viewtopic.php?f=3&t=16121
Steps To Reproduce1. Start with new document in FC17.
2. Create body.
3. Create basic block through the normal sketch and pad procedures.
4. Create helper pad by creating sketch on top face of basic block and padding.
5. Create prototype hole by creating sketch on top face of block and pocketing.
6. Create polar pattern.
-- Set the number of holes.
-- Choose "Select reference..." in the axis drop-down menu item and click on a vertical edge of the helper pad.
-- No error messages, but the axis does not change.
-- Log trace shows the correct axis is selected, but when the "OK" is clicked to finish the polar task the axis reverts back to (0,0,0).
Additional InformationOS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7709 (Git)
Build type: Release
Branch: master
Hash: 7f2833b465f544a8d49a36382c00e7c9c85a4abb
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17


TagsNo tags attached.
FreeCAD Information

Activities

normandc

2016-06-25 20:43

manager   ~0007156

FYI "helper pads" were a workaround used to circumvent the fact that sketches needed to be mapped to planar faces for PartDesign features to be added to/subtracted from a part. This workaround is no longer necessary in 0.17 since the merge of PartDesign Next and the introduction of the Body container. You should not expect the workflow you were used to in 0.16 to be the same in 0.17.

normandc

2016-06-25 20:53

manager   ~0007157

That being said, I confirm that "Select reference..." is not working.

OS: Ubuntu 14.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7797 (Git)
Build type: None
Branch: master
Hash: 1408f0cd0a2912b72839c46877d58e0a24f0240b
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

normandc

2016-06-25 20:56

manager  

test_017_polarpattern.fcstd (30,051 bytes)

normandc

2016-06-25 20:59

manager   ~0007158

Attached case file for review.

1. Edit PolarPattern
2. In the "Axis" field, pick "Select reference..."
3. Select either Edge26 or DatumLine.
4. Selection has no effect.

Related Changesets

FreeCAD: master cdf43744

2016-10-05 05:45:42

poserge


Committer: wmayer Details Diff
PD: fix 0002582 Affected Issues
0002582
mod - src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp Diff File
mod - src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp Diff File

Issue History

Date Modified Username Field Change
2016-06-11 01:08 GeneFC New Issue
2016-06-25 20:43 normandc Note Added: 0007156
2016-06-25 20:53 normandc Note Added: 0007157
2016-06-25 20:56 normandc File Added: test_017_polarpattern.fcstd
2016-06-25 20:59 normandc Note Added: 0007158
2016-10-15 15:42 wmayer Changeset attached => FreeCAD Master master cdf43744
2016-10-15 15:42 wmayer Assigned To => wmayer
2016-10-15 15:42 wmayer Status new => closed
2016-10-15 15:42 wmayer Resolution open => fixed
2016-10-15 15:43 wmayer Fixed in Version => 0.17