View Issue Details

IDProjectCategoryView StatusLast Update
0002553Path[FreeCAD] Featurepublic2018-05-13 16:28
Reportersliptonic Assigned Tomlampert  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformPCOSDebianOS VersionTesting 64bit
Product Version 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0002553: 4th axis paths don't display as expected
DescriptionIssue imported from https://github.com/yorikvanhavre/FreeCAD/issues/7

 sliptonic commented on 14 Dec 2014

4th axis paths don't display as expected
In the image, you can see a 2 axis gcode file that has had the Y axis coordinates mapped onto th A axis.
Gcode Ripper is able to display the gcode as it would appear. This is done by selecting the view plane (ISO1).

User should be able to visualize the path as it would appear.

selection_028
TagsNo tags attached.

Activities

yorik

2016-05-13 22:06

administrator   ~0007101

sliptonic commented on 15 Dec 2014

Here's a 4th axis toolpath.
https://dl.dropboxusercontent.com/u/9245675/fish_wrap.ngc

yorik

2016-05-13 22:07

administrator  

fish_wrap.ngc (31,165 bytes)

yorik

2016-05-13 22:07

administrator   ~0007102

yorikvanhavre commented on 29 Dec 2014

I'm not sure how this should be done? Isn't it better to have a special pre_ script that maps all A values to Y?

yorik

2016-05-13 22:07

administrator   ~0007103

sliptonic commented on 29 Dec 2014

No, that would undo what we're trying to do. Gcoderipper is easy to install and can be downloaded here: http://www.scorchworks.com/ It's the program running in the middle of the image above. It has a number of interesting features for working with paths.

In this case, it's taking a 2D path in XYZ and mapping the Y axis moves onto A axis with a given diameter. This effectively 'wraps' the engraving around the cylinder.

However, if I import that path into FreeCAD, it doesn't look like the wrapped cylinder since no A moves are shown. Somehow, GcodeRipper addresses this with the ISO views.

yorik

2016-05-13 22:08

administrator   ~0007104

yorikvanhavre commented on 29 Dec 2014

I can't make the g-code ripper program display the same thing as in your screenshot with the file linked above... It keeps telling me "Aborting G-Code Reading: A Codes are not supported". Is there any other option to configure?

Anyway it is still not clear to me what we need to achieve, if it is not mapping the A values to X or Y?

yorik

2016-05-13 22:08

administrator   ~0007105

yorikvanhavre commented on 29 Dec 2014

(18:01:42) sliptonic: Here's an application. https://www.youtube.com/watch?v=dblNnF4JJGk Ideally, the path visualization after wrapping would look something like this: http://www.cnczone.com/forums/attachment.php?attachmentid=90480&stc=1&thumb=1&d=1389517864
(18:06:08) sliptonic: Another image: http://www.cnczone.com/forums/attachment.php?attachmentid=186056&d=1389534069&thumb=1

yorik

2016-05-13 22:08

administrator   ~0007106

yorikvanhavre commented on 11 Apr 2015

This is not that easy... It really involves building a complex, new display mode to show/map the paths on a cylinder... I suggest we leave that for after the merge

Kunda1

2017-02-04 03:50

administrator  

sliptonic

2017-11-28 00:57

developer   ~0010486

Moving to 0.18 target

mlampert

2018-05-08 21:29

developer   ~0011240

https://github.com/FreeCAD/FreeCAD/pull/1450/commits/352ba3b0a8500a75f953fa39fbe2cb3327ae9c71

Issue History

Date Modified Username Field Change
2016-05-13 22:06 yorik New Issue
2016-05-13 22:06 yorik File Added: 0178ba9c-83a2-11e4-933d-f891256e1317.png
2016-05-13 22:06 yorik Reporter yorik => sliptonic
2016-05-13 22:06 yorik Note Added: 0007101
2016-05-13 22:07 yorik File Added: fish_wrap.ngc
2016-05-13 22:07 yorik Note Added: 0007102
2016-05-13 22:07 yorik Note Added: 0007103
2016-05-13 22:08 yorik Note Added: 0007104
2016-05-13 22:08 yorik Note Added: 0007105
2016-05-13 22:08 yorik Note Added: 0007106
2017-02-04 03:50 Kunda1 File Added: 0178ba9c-83a2-11e4-933d-f891256e1317.jpg
2017-02-04 03:51 Kunda1 File Deleted: 0178ba9c-83a2-11e4-933d-f891256e1317.png
2017-11-28 00:57 sliptonic Product Version 0.16 =>
2017-11-28 00:57 sliptonic Target Version => 0.18
2017-11-28 00:57 sliptonic Note Added: 0010486
2018-05-08 21:28 mlampert Assigned To => mlampert
2018-05-08 21:28 mlampert Status new => assigned
2018-05-08 21:29 mlampert Note Added: 0011240
2018-05-11 20:41 mlampert Status assigned => resolved
2018-05-11 20:41 mlampert Resolution open => fixed
2018-05-11 20:41 mlampert Fixed in Version => 0.18
2018-05-13 16:28 wmayer Status resolved => closed