View Issue Details

IDProjectCategoryView StatusLast Update
0002537PartDesignBugpublic2016-05-18 22:23
ReporterjkpAssigned Toickby 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.11.4
Product Version 
Target VersionFixed in Version0.17 
Summary0002537: Can't create pocket from sketch with multiple geometries.
DescriptionWhen I try to create a pocket from a sketch with multiple geometries, say two circles, I get a "TopoDS::Face" error.
Steps To Reproduce1. Start FreeCAD
2. New Document
3. Go to Part Design
4. Create rectangle and fully constrain it.
5. Pad rectangle to create a box
6. Select top face, create new sketch on that face.
7. Create two circles and constrain both of them to make sketch fully constrained.
8. Close sketch
9. Select pocket, choose default parameters.
10. Dialog with "TopoDS::Face" popus up. Pocket is not created.
Additional InformationFreecad version:
OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7463 (Git)
Build type: Release
Branch: (detached from e50950f)
Hash: e50950f070a5c188fd8c6b7220bf445b7f2b410b
Python version: 2.7.11
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17


Text from Python Console:
>>> Gui.activeDocument().hide("Sketch001")
>>> App.ActiveDocument.Pocket.Length = 5.000000
>>> App.ActiveDocument.Pocket.Type = 1
>>> App.ActiveDocument.Pocket.UpToFace = None
>>> App.ActiveDocument.Pocket.Reversed = 0
>>> App.ActiveDocument.Pocket.Midplane = 0
>>> App.ActiveDocument.Pocket.Offset = 0.000000
>>> Gui.activeDocument().hide("Pad")
>>> App.ActiveDocument.recompute()
TagsNo tags attached.

Relationships

duplicate of 0002512 closedickby Pad/Pocket does not work with independent figures in sketch (new Partdesign) 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-04-30 22:29 jkp New Issue
2016-05-02 06:28 ickby Relationship added duplicate of 0002512
2016-05-02 06:29 ickby Assigned To => ickby
2016-05-02 06:29 ickby Status new => assigned
2016-05-18 22:23 wmayer Status assigned => closed
2016-05-18 22:23 wmayer Resolution open => fixed
2016-05-18 22:23 wmayer Fixed in Version => 0.17