View Issue Details

IDProjectCategoryView StatusLast Update
0002525FreeCADBugpublic2016-05-13 03:58
Reporterrevolver1941Assigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel 64-bitOSWindowsOS Version10
Product Version 
Target VersionFixed in Version0.17 
Summary0002525: Line color of shapes are always black
DescriptionAll the Line Color of shapes always turns into black when re-open a .FCStd file only by version 0.17.
A topic in forum http://forum.freecadweb.org/viewtopic.php?f=8&t=15475
Steps To ReproduceRun FreeCAD.
Switch to part workbench.
Create a cube or something others.
Set the cube's Line Color into any color except black.
Save the .FCStd document.
Close FreeCAD.
Run FreeCAD again.
Open the previous saved .FCStd document.
Then you found the cube's Line Color turns into black although the property value has not changed.
TagsNo tags attached.

Activities

revolver1941

2016-04-27 06:54

reporter  

4.PNG (Attachment missing)

revolver1941

2016-04-27 06:57

reporter   ~0007011

OS: Windows 8
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7447 (Git)
Build type: Release
Branch: master
Hash: 898bd8bb4cbe2c9b26aa6c1f7362e48752a3e4de
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

revolver1941

2016-04-27 06:57

reporter  

3.PNG (Attachment missing)

wmayer

2016-05-06 09:01

administrator   ~0007054

A new property "LineColorArray" has been introduced to allow to set individual colors for the edges. However, the two properties are not synchronized so that the reading of the LineColorArray overwrites the correct colors again.

For the moment it must made sure to synchronize the properties. In the long term it's best to have only one property and remove the others.

Responsible commit:
https://github.com/FreeCAD/FreeCAD/commit/af25c0c7939aa04616dbfd0a220a42d159c67326

wmayer

2016-05-06 10:18

administrator   ~0007056

Note to myself:

Implement the class PropertyMaterialList and use this for vertex, edge and face colors.

wmayer

2016-05-06 12:00

administrator   ~0007061

The actual issue has been resolved now. But note since projects created with 0.17 contain the inconsistent colors the lines will still be black. You first have to fix the colors and save the file again. Afterwards the load works as expected.

I leave this ticket open because for the long-term solution still a lot of things must be implemented.

Related Changesets

FreeCAD: master 7e01d012

2016-05-06 13:57:13

wmayer

Details Diff
+ issue 0002525: Line color of shapes are always black Affected Issues
0002525
mod - src/Mod/Part/Gui/ViewProviderExt.cpp Diff File

FreeCAD: master 317b447f

2016-05-07 14:41:24

wmayer

Details Diff
+ implement PropertyMaterialList Affected Issues
0002525
mod - src/App/Application.cpp Diff File
mod - src/App/FeatureTest.cpp Diff File
mod - src/App/FeatureTest.h Diff File
mod - src/App/PropertyStandard.cpp Diff File
mod - src/App/PropertyStandard.h Diff File

FreeCAD: master 8bbc6421

2016-05-07 22:11:37

wmayer

Details Diff
+ editor for PropertyMaterial Affected Issues
0002525
mod - src/App/FeatureTest.cpp Diff File
mod - src/App/PropertyStandard.cpp Diff File
mod - src/App/PropertyStandard.h Diff File
mod - src/Gui/SoFCDB.cpp Diff File
mod - src/Gui/propertyeditor/PropertyItem.cpp Diff File
mod - src/Gui/propertyeditor/PropertyItem.h Diff File

Issue History

Date Modified Username Field Change
2016-04-27 06:54 revolver1941 New Issue
2016-04-27 06:54 revolver1941 File Added: 4.PNG
2016-04-27 06:57 revolver1941 Note Added: 0007011
2016-04-27 06:57 revolver1941 File Added: 3.PNG
2016-05-06 09:01 wmayer Note Added: 0007054
2016-05-06 09:01 wmayer Assigned To => wmayer
2016-05-06 09:01 wmayer Status new => confirmed
2016-05-06 10:18 wmayer Note Added: 0007056
2016-05-06 11:57 wmayer Changeset attached => FreeCAD Master master 7e01d012
2016-05-06 12:00 wmayer Note Added: 0007061
2016-05-06 12:00 wmayer Status confirmed => resolved
2016-05-06 12:00 wmayer Fixed in Version => 0.17
2016-05-06 12:00 wmayer Resolution open => fixed
2016-05-07 12:42 wmayer Changeset attached => FreeCAD Master master 317b447f
2016-05-07 21:25 wmayer Changeset attached => FreeCAD Master master 8bbc6421
2016-05-13 03:58 yorik Status resolved => closed