View Issue Details

IDProjectCategoryView StatusLast Update
0002517PartDesignBugpublic2017-09-13 11:23
ReporterwmayerAssigned Toickby 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0002517: Some oddities with shape binder
DescriptionWhen I create a body and then click on the shape binder icon I get flooded with the messages:
not a dag exception in DAGView::Model::updateSlot()

With a press on Cancel the added ShapeBinder object won't be deleted. And since it's in edit mode you first have to leave edit mode so that it can be manually deleted.


When I create e.g. a standard box before then I can safely invoke the shape binder. Now when pressing the "Add geometry" button I can select a face of the box but then in the output window an error essage comes up:
Unhandled unknown exception caught in GUIApplication::notify.

Any attempts to add further geometries or remove the added one doesn't work. You always get the above error message. When clicking on OK an occ error comes up:
Access violation at address 0x000000 during READ operation

After pressing Cancel to leave the shape binder and you do a double-click on the icon the error comes up "Unknown C++ exception" but it enters into label edit mode instead of entering the shape binder edit mode as one would assume with the bold text of its context-menu.

If I open the context-menu and invoke Edit shape binder again this error message comes up:
Unhandled unknown exception caught in GUIApplication::notify.

After trying a while I do not even know what the shape binder is good for as wasn't able to get it working at all.

TagsDAG, shapebinder

Activities

wmayer

2016-04-24 16:06

administrator   ~0007000

The crash happens inside ShapeBinder::getFilterdReferences. The list 'objs' contains a single element which is a nullptr that's why it crashes at: while(!objs[index]->isDerivedFrom(Part::Feature::getClassTypeId()) && index < objs.size())

So, the actual bug already happens in TaskShapeBinder::referenceSelected where it sets the selection:
static_cast<PartDesign::ShapeBinder*>(vp->getObject())->Support.setValue(obj, refs);
'obj' is a nullptr here.

normandc

2017-06-18 00:07

manager   ~0009435

I can't reproduce. Was this fixed?

Kunda1

2017-06-21 10:36

manager   ~0009476

@wmayer can you still reproduce this?

normandc

2017-07-09 20:41

manager   ~0009699

Further feedback needed to confirm whether the issue still exists or not.

Kunda1

2017-08-13 16:58

manager   ~0009917

@wmayer please weigh in when you have a moment. thanks!

wmayer

2017-08-30 18:06

administrator   ~0010049

The not-a-DAG error messages are still there and also trying to add geometry to the shape binder leads to a crash.

The only point that is fixed so far is pressing the Cancel button to delete the shape binder object.

wmayer

2017-09-10 12:20

administrator   ~0010102

https://github.com/FreeCAD/FreeCAD/commit/756ed3381e65e9744790710c4a6338a64394e93e fixes the crash in ShapeBinder::getFilterdReferences

wmayer

2017-09-13 11:23

administrator   ~0010111

The DAG issue is fixed in https://github.com/FreeCAD/FreeCAD/commit/f663a754c85cfe39aa4850827fecae7f524e4ae5

Issue History

Date Modified Username Field Change
2016-04-21 08:58 wmayer New Issue
2016-04-21 08:58 wmayer Status new => assigned
2016-04-21 08:58 wmayer Assigned To => ickby
2016-04-24 16:06 wmayer Note Added: 0007000
2017-02-17 10:56 Kunda1 Tag Attached: DAG
2017-06-18 00:07 normandc Note Added: 0009435
2017-06-21 10:34 Kunda1 Tag Attached: shapebinder
2017-06-21 10:36 Kunda1 Note Added: 0009476
2017-06-21 10:37 Kunda1 Target Version => 0.17
2017-07-09 20:41 normandc Status assigned => feedback
2017-07-09 20:41 normandc Note Added: 0009699
2017-08-13 16:58 Kunda1 Note Added: 0009917
2017-08-30 18:06 wmayer Note Added: 0010049
2017-08-30 18:06 wmayer Status feedback => assigned
2017-09-10 12:20 wmayer Note Added: 0010102
2017-09-13 11:23 wmayer Status assigned => closed
2017-09-13 11:23 wmayer Resolution open => fixed
2017-09-13 11:23 wmayer Fixed in Version => 0.17
2017-09-13 11:23 wmayer Note Added: 0010111