View Issue Details

IDProjectCategoryView StatusLast Update
0002511PartDesignBugpublic2017-05-31 01:02
Reporterulrich1aAssigned Toabdullah 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0002511: Failing adding xy-datum-plane in example-cylinder
DescriptionThis report is about "PartDesign Next" in 0.17 development version
Deepsoic did post an cylinder with tangent datum planes. It is not possible to add a xy-datum-plane to the body. Nothing happens at clicking the button, no warnings, no new datum-plane.
Steps To Reproduce- open the file below
- select the xy-plane in the body
- click create datum-plane in the task-view

Nothing happens.
Additional InformationOS: Debian GNU/Linux 8.4 (jessie)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7405 (Git)
Build type: Release
Branch: remotes/origin/master
Hash: de1b04afa6136174dcd89d8a8a1d6aae5e0a847a
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Activities

ulrich1a

2016-04-16 14:11

reporter  

datum planes attached to cylinder.FCStd (9,178 bytes)

DeepSOIC

2016-04-16 14:45

developer   ~0006977

Workaround (and possibly, explanation):
Double-click the body to make it active. Then, datum planes can be made.

wmayer

2016-04-16 16:21

administrator   ~0006980

There is a function "UnifiedDatumCommand" that calls PartDesignGui::getBody which shows up a message dialog that there's no active body. But therefore the parameter should be set to "!bEditSelected" instead of "false".

Kunda1

2017-02-19 14:56

administrator   ~0008369

@wmayer can you offer some insight how to proceed with this ticket? Shall i post it to the forum? Or perhaps mention something to ickby ?

DeepSOIC

2017-02-19 19:00

developer   ~0008372

The lack of datum plane is not a bug. Bug is that datum plane button does nothing at all, IMO. Either a message should pop up, or a line should be printed to console. Or the button should be simply disabled until one activates a body.

abdullah

2017-05-30 22:18

manager   ~0009202

I agree with DeepSOIC.

A pop-up added in:
https://github.com/FreeCAD/FreeCAD/pull/792

wmayer

2017-05-31 01:02

administrator   ~0009211

https://github.com/FreeCAD/FreeCAD/commit/4b042536f8c93caae09040a32473343ac3b24775

Issue History

Date Modified Username Field Change
2016-04-16 14:11 ulrich1a New Issue
2016-04-16 14:11 ulrich1a File Added: datum planes attached to cylinder.FCStd
2016-04-16 14:45 DeepSOIC Note Added: 0006977
2016-04-16 16:21 wmayer Note Added: 0006980
2017-02-19 14:23 Kunda1 Product Version => 0.17
2017-02-19 14:56 Kunda1 Note Added: 0008369
2017-02-19 19:00 DeepSOIC Note Added: 0008372
2017-03-10 06:32 Kunda1 Target Version => 0.17
2017-05-30 22:18 abdullah Note Added: 0009202
2017-05-30 22:18 abdullah Assigned To => abdullah
2017-05-30 22:18 abdullah Status new => assigned
2017-05-31 01:02 wmayer Status assigned => closed
2017-05-31 01:02 wmayer Resolution open => fixed
2017-05-31 01:02 wmayer Fixed in Version => 0.17
2017-05-31 01:02 wmayer Note Added: 0009211