View Issue Details

IDProjectCategoryView StatusLast Update
0002503PartDesignBugpublic2017-02-10 16:19
ReporterwmayerAssigned Toickby 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.17 
Summary0002503: Invisible pad object
DescriptionFor some PartDesign operations the object is outside the camera's frustum and you have to invoke the Fit All. However, the Fit All command is not part of the context-menu so that you have to move to the toolbars and back to the 3d view which is a bit annoying.
Steps To Reproduce1. Create a body
2. Create a sketch and draw a rectangle
3. Make a pad => the object is outside the view frustum. You have to invoke Fit All to make it visible.
TagsNo tags attached.

Activities

ickby

2016-04-14 11:46

developer   ~0006966

I see the described behavior. I'm not yet sure what the best way for going forward is, as I do not know why the view frustrum has this strange size/placement. I will investigate.

wmayer

2016-04-16 20:14

administrator   ~0006981

When testing this with 0.16 then camera settings at document creation are:
#Inventor V2.1 ascii

OrthographicCamera {
  viewportMapping ADJUST_CAMERA
  position 0 0 1
  orientation 0 0 1 0
  aspectRatio 1
  focalDistance 5
  height 4.1421356
}

When creating the sketch the settings will change to:
#Inventor V2.1 ascii


OrthographicCamera {
  viewportMapping ADJUST_CAMERA
  position 0 0 87
  orientation 0 0 1 0
  nearDistance 86.905006
  farDistance 87.087006
  aspectRatio 1
  focalDistance 87
  height 143.52005

}
and then the pad just shows fine afterwards.

In version 0.17 the camera settings don't change much when creating the sketch:
#Inventor V2.1 ascii


OrthographicCamera {
  viewportMapping ADJUST_CAMERA
  position 0 0 1
  orientation 0 0 1 0
  nearDistance 0.99100798
  farDistance 1.001
  aspectRatio 1
  focalDistance 5
  height 4.1421356

}

When changing the camera settings in 0.17 with Gui.ActiveDocument.ActiveView.setCamera then the pad also will be visible on creation.

So, the question is why the camera settings don't change on sketch creation like in 0.16.

wmayer

2016-04-16 20:36

administrator   ~0006982

In version 0.16 it works because the camera settings are explicitly changed when the sketch is the first object in the modelling history. Maybe this idea should be applied when mapping the sketch on a base plane.

https://github.com/FreeCAD/FreeCAD/blob/releases/FreeCAD-0-16/src/Mod/Sketcher/Gui/Command.cpp#L132

Related Changesets

FreeCAD: master 798a57e2

2017-02-10 16:19:01

wmayer

Details Diff
issue 0002503: Invisible pad object Affected Issues
0002503
mod - src/Mod/PartDesign/Gui/CommandBody.cpp Diff File

Issue History

Date Modified Username Field Change
2016-04-14 10:13 wmayer New Issue
2016-04-14 10:13 wmayer Status new => assigned
2016-04-14 10:13 wmayer Assigned To => ickby
2016-04-14 11:46 ickby Note Added: 0006966
2016-04-14 11:46 ickby Status assigned => confirmed
2016-04-16 20:14 wmayer Note Added: 0006981
2016-04-16 20:36 wmayer Note Added: 0006982
2017-02-10 16:19 wmayer Changeset attached => FreeCAD Master master 798a57e2
2017-02-10 16:19 wmayer Status confirmed => closed
2017-02-10 16:19 wmayer Resolution open => fixed
2017-02-10 16:19 wmayer Fixed in Version => 0.17