View Issue Details

IDProjectCategoryView StatusLast Update
0002496DraftBugpublic2017-08-28 18:17
ReportersliptonicAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.17 
Summary0002496: DraftGeomUtils.FindWires doesn't find all
DescriptionPassing in a set of edges to DraftGeomUtils.findWires(), I would expect to get back a list of all wires in the set. However, an incomplete set is returned under some conditions.
Steps To ReproduceRun this macro:

import DraftGeomUtils

App.ActiveDocument.addObject("Part::Box","Box")
App.ActiveDocument.ActiveObject.Label = "Cube"
App.ActiveDocument.recompute()

obj = App.ActiveDocument.ActiveObject
print "The box object has " + str(len(obj.Shape.Edges)) + " edges"
print "length of obj.Shape.Wires: " + str(len(obj.Shape.Wires))


x =0
for f in obj.Shape.Faces:
    x += len(f.Wires)
print "Total found by counting wires in object faces: " + str(x)

print "wires found by DraftGeomUtils.findWires(obj.Shape.Edges) : " + str(len(DraftGeomUtils.findWires(obj.Shape.Edges)))
Additional Informationoutput on my system:

The box object has 12 edges
length of obj.Shape.Wires: 6
Total found by counting wires in object faces: 6
wires found by DraftGeomUtils.findWires(obj.Shape.Edges) : 1
TagsNo tags attached.

Activities

yorik

2016-04-26 22:50

administrator   ~0007009

will look into it

Kunda1

2017-08-28 16:24

manager   ~0010027

Opened forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=24099

amrit3701

2017-08-28 17:56

reporter   ~0010028

I have replied on a forum.

Kunda1

2017-08-28 18:06

manager   ~0010029

@sliptonic can you retest and see if this issue still exists for you?
It seems @amrit3701 can't reproduce it.

sliptonic

2017-08-28 18:10

developer   ~0010030

re-ran test. No longer shows incorrect results. No idea when it was fixed.

Kunda1

2017-08-28 18:17

manager   ~0010031

Closing

Issue History

Date Modified Username Field Change
2016-04-06 01:18 sliptonic New Issue
2016-04-26 22:50 yorik Note Added: 0007009
2016-04-26 22:50 yorik Assigned To => yorik
2016-04-26 22:50 yorik Status new => assigned
2017-08-28 16:24 Kunda1 Note Added: 0010027
2017-08-28 17:56 amrit3701 Note Added: 0010028
2017-08-28 18:06 Kunda1 Note Added: 0010029
2017-08-28 18:10 sliptonic Status assigned => resolved
2017-08-28 18:10 sliptonic Resolution open => fixed
2017-08-28 18:10 sliptonic Fixed in Version => 0.17
2017-08-28 18:10 sliptonic Note Added: 0010030
2017-08-28 18:17 Kunda1 Status resolved => closed
2017-08-28 18:17 Kunda1 Note Added: 0010031