View Issue Details

IDProjectCategoryView StatusLast Update
0002493PartDesignBugpublic2017-10-01 22:59
Reporterbibomator Assigned Towmayer  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSLinuxOS VersionLinux Mint 17.1
Product Version0.16 
Target Version0.17Fixed in Version0.17 
Summary0002493: [0.16] crash when adding slot
Descriptionafter adding a slot in the sketch and ending the creation Freecad crashes
Steps To Reproduce1) open attached file
2) Open the Sketch "Sketch"
3) Switch to Part designer
4) Add a slot to the sketch
5) press escape to exit the slot dialog

--> Program will crash within some seconds
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0002672 closedkkremitzki Sketcher Sketcher symmetry tool segfaults 

Activities

bibomator

2016-04-04 20:17

reporter  

bosch_konsole3.fcstd (Attachment missing)

eivindkvedalen

2016-04-04 20:29

developer   ~0006944

Confirmed with assertion FreeCAD: SoGroup.cpp:292: virtual SoNode* SoGroup::getChild(int) const: Assertion `(index >= 0) && (index < this->getNumChildren())' failed.

maiden

2016-12-01 21:21

reporter  

A2212Attachment1.fcstd (Attachment missing)

maiden

2016-12-01 21:23

reporter   ~0007503

I get the exact same fault with the appended file, open file, in part design try to create a sketch on the surface with the hole, then draw a rect on the sketch and it will crash. running latest git on Ubuntu 16.10

maiden

2016-12-02 12:02

reporter   ~0007505

Ah, made a git clean, followed by "make clean", that resolved the problem for me. turned out i had 20+ old .cpp, .py and .h files that was no longer in the git repo.

maiden

2016-12-03 13:14

reporter   ~0007511

got the issue again on the new build.

normandc

2016-12-16 03:15

manager   ~0007527

Last edited: 2016-12-16 03:15

View 2 revisions

maiden, "the new build" is meaningless. Please provide your full FreeCAD info as explaining here: http://forum.freecadweb.org/viewtopic.php?f=3&t=2264

Your file's Dependency Graph looks very weird as there are arrows pointing to Pad from Pocket and Sketch001, they shouldn't be there. Please explain in detail how you built this model.

FreeCAD info should look like this:
OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9244 (Git)
Build type: None
Branch: master
Hash: 6d1eddc22f9f3176cea96b34d5002e84e29550d4
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-01-13 20:44

administrator   ~0007728

@bibomator please respond to @normandc queries in 0002493:0007527

maiden

2017-01-16 08:11

reporter   ~0007807

Last edited: 2017-01-16 08:17

View 3 revisions

I think it might be related to the issue i described here:
http://forum.freecadweb.org/viewtopic.php?f=10&t=18985&p=147992#p147992

OS: Ubuntu 16.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9586 (Git)
Build type: Unknown
Branch: master
Hash: 0e2cf2ebcaaa50723de608cf030af740cb6ad548
Python version: 2.7.12+
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-01-16 08:30

administrator   ~0007811

Last edited: 2017-01-16 08:31

View 2 revisions

@bibomator could you also provide a detailed step-by-step as was requested above? Just linking to that forum thread might not be enough for the devs to ascertain the issue. Thanks

bibomator

2017-01-17 18:57

reporter   ~0007844

@Kunda1
I can't explain what the User maiden did and how he constructed the model. I just can speak for the model saved in file bosch_konsole3.fcstd which was created by me (the other attachment was not) hence I cant explain http://freecadweb.org/tracker/view.php?id=2493#c7527
I just could reproduce the crash with my latest installation which is 0.16, Git 6707 following the steps in the field "steps to reproduce"

1) open attached file (bosch_konsole3.fcstd)
2) Open the Sketch "Sketch"
3) Switch to Part designer
4) Add a slot to the sketch

The slot is not added and after some time the program crashes.

Please describe what additional information you need.

Kunda1

2017-01-17 19:46

administrator   ~0007846

@bibomator please paste the output from Help > About FreeCAD > Copy to clipboard

bibomator

2017-01-17 19:50

reporter   ~0007847

OS: Ubuntu 16.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6707 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 5465bc47c95db45e0be85dc0e2872419efadce0f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-01-18 02:05

administrator   ~0007862

Thanks @bibomator

@eivindkvedalen wrote in 0002493:0006944
Confirmed with assertion FreeCAD: SoGroup.cpp:292: virtual SoNode* SoGroup::getChild(int) const: Assertion `(index >= 0) && (index < this->getNumChildren())' failed. 

Kunda1

2017-04-28 12:07

administrator   ~0008795

@kkremitzki can you please move this in to 'Part' category? ( I believe that is correct, right?) Thx!

kkremitzki

2017-05-16 14:45

administrator   ~0009032

@Kunda1 moved

normandc

2017-06-18 01:04

manager   ~0009440

can you please move this in to 'Part' category? ( I believe that is correct, right?)

Kunda1
It's not correct. This has nothing to do with Part, the two people affected by this bug very clearly mention the PartDesign workbench.

The bosch_konsole3.fcstd file is no longer available. I cannot confirm this issue.

Kunda1

2017-06-18 19:31

administrator   ~0009452

Last edited: 2017-06-18 19:32

View 2 revisions

@normandc my bad. Thanks for the correction.
@bibomator can you re-up your original attachment? It didn't survive a restore we needed to run on the tracker. Thanks in advance!

Kunda1

2017-07-03 21:16

administrator   ~0009659

@bibomator ping

Kunda1

2017-09-22 19:46

administrator   ~0010157

@bibomator ping

bibomator

2017-09-23 08:12

reporter   ~0010160

Hi - sorry I don't have the file which cause the crash anymore. I recreated the design after fileing the bug but didn't think about preserving the file...

Kunda1

2017-09-24 11:33

administrator   ~0010166

@wmayer please advise on how to proceed with this ticket (since we don't have the example file anymore to trigger the bug)?

wmayer

2017-09-25 20:48

administrator   ~0010193

I assume the issue has been fixed with this change: https://github.com/FreeCAD/FreeCAD/commit/3d86498a43568770c619427169951535d8e3ba4e#diff-0e7a6053fe9b35a7f7445e53ce49d08e

Kunda1

2017-09-26 15:14

administrator   ~0010194

A-OK, resolving then and deferring to dev to close it.

Issue History

Date Modified Username Field Change
2016-04-04 20:17 bibomator New Issue
2016-04-04 20:17 bibomator File Added: bosch_konsole3.fcstd
2016-04-04 20:29 eivindkvedalen Note Added: 0006944
2016-12-01 21:21 maiden File Added: A2212Attachment1.fcstd
2016-12-01 21:23 maiden Note Added: 0007503
2016-12-02 12:02 maiden Note Added: 0007505
2016-12-03 13:14 maiden Note Added: 0007511
2016-12-16 03:15 normandc Note Added: 0007527
2016-12-16 03:15 normandc Note Edited: 0007527 View Revisions
2017-01-13 20:44 Kunda1 Note Added: 0007728
2017-01-13 20:44 Kunda1 Status new => feedback
2017-01-16 08:11 maiden Note Added: 0007807
2017-01-16 08:15 maiden Note Edited: 0007807 View Revisions
2017-01-16 08:17 maiden Note Edited: 0007807 View Revisions
2017-01-16 08:30 Kunda1 Note Added: 0007811
2017-01-16 08:30 Kunda1 Status feedback => new
2017-01-16 08:31 Kunda1 Note Edited: 0007811 View Revisions
2017-01-16 08:31 Kunda1 Status new => feedback
2017-01-17 18:57 bibomator Note Added: 0007844
2017-01-17 18:57 bibomator Status feedback => new
2017-01-17 19:46 Kunda1 Note Added: 0007846
2017-01-17 19:46 Kunda1 Status new => feedback
2017-01-17 19:50 bibomator Note Added: 0007847
2017-01-17 19:50 bibomator Status feedback => new
2017-01-18 02:05 Kunda1 Note Added: 0007862
2017-01-23 22:12 wmayer Relationship added related to 0002672
2017-02-15 06:00 kkremitzki Status new => confirmed
2017-02-15 06:00 kkremitzki Target Version => 0.17
2017-04-28 12:07 Kunda1 Note Added: 0008795
2017-04-28 12:08 Kunda1 Product Version => 0.16
2017-05-16 14:44 kkremitzki Project FreeCAD => Part
2017-05-16 14:45 kkremitzki Note Added: 0009032
2017-06-18 01:04 normandc Note Added: 0009440
2017-06-18 01:04 normandc Project Part => PartDesign
2017-06-18 19:31 Kunda1 Status confirmed => feedback
2017-06-18 19:31 Kunda1 Note Added: 0009452
2017-06-18 19:32 Kunda1 Note Edited: 0009452 View Revisions
2017-07-03 21:16 Kunda1 Note Added: 0009659
2017-09-22 19:46 Kunda1 Note Added: 0010157
2017-09-23 08:12 bibomator Note Added: 0010160
2017-09-23 08:12 bibomator Status feedback => new
2017-09-24 11:33 Kunda1 Note Added: 0010166
2017-09-25 20:48 wmayer Note Added: 0010193
2017-09-26 15:14 Kunda1 Assigned To => wmayer
2017-09-26 15:14 Kunda1 Status new => resolved
2017-09-26 15:14 Kunda1 Resolution open => fixed
2017-09-26 15:14 Kunda1 Fixed in Version => 0.17
2017-09-26 15:14 Kunda1 Note Added: 0010194
2017-10-01 22:59 wmayer Status resolved => closed