View Issue Details

IDProjectCategoryView StatusLast Update
0002492SketcherFeaturepublic2018-10-06 15:00
Reportermimosa Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status newResolutionopen 
PlatformPCOSWindowsOS Version10
Product Version0.15 
Target Version0.19Fixed in Version 
Summary0002492: Multiple entities overlayed
DescriptionWhen more than one entity are overlayed (two lines, a line and the reference horizontal, 2 points, a point and the end point of a line, etc) the user should be able to chose which entity to interact with:

1) User would hover the mouse over (near) the area of interest,
2) If in that zone surrounding the mouse there exist more than one entity, after 2 second, a little button would appear (say, with 3 dots as a text)
3) when the button is clicked, a list would popup listing all the selectable entities in the vicinity
4) the user can select an entity (or close the popup without selecting any) and the program would continue (either the user was in the middle of an operation, ir want to start an operation with the selected entity).
TagsNo tags attached.
FreeCAD Information

Activities

normandc

2016-04-05 00:34

manager   ~0006946

Last edited: 2016-04-05 00:35

View 2 revisions

There's already a mechanism to select overlapping sketch entities in v0.16 due to come out shortly.

normandc

2018-01-06 19:16

manager   ~0010724

@abdullah @wmayer

Should this be closed as fixed? In v0.17's Sketcher, we can now define the display order of normal/construction/reference geometry.

But this would not solve the issue where two lines of the same type are overlapping.

abdullah

2018-01-11 10:13

manager   ~0010737

@normandc

I think it is an open point in the sketcher.

All you say is absolutely right, v.17 (probably also 0.16) has the elements widget which allows any selection. In this sense it is not a bug (but this ticket was opened as a feature).

The new rendering order in v.17 will help as you comment... except in that case of two overlapping lines of the same type and one is fully overlapped by the other.

So let's say that the current implementation can be improved.

Eventually, the whole inner parts of sketcher visualization (interface with coin3d) will need to be rewritten. It may be that in that effort this feature is "rescued".

Issue History

Date Modified Username Field Change
2016-04-03 05:05 mimosa New Issue
2016-04-05 00:34 normandc Note Added: 0006946
2016-04-05 00:35 normandc Note Edited: 0006946 View Revisions
2018-01-06 19:16 normandc Note Added: 0010724
2018-01-11 10:13 abdullah Note Added: 0010737
2018-10-06 15:00 abdullah Target Version => 0.19