View Issue Details

IDProjectCategoryView StatusLast Update
0002473FreeCADFeaturepublic2017-01-31 18:03
ReporterSpindoctorAssigned Toeivindkvedalen 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002473: Spreadsheet - additional syntax for aggregate functions
DescriptionThe wiki states about aggregate functions:

The following aggregate functions are supported: average, count, max, min, stddev, sum.
Aggregate functions are written with a colon: =average(B1:B8)

This is however not convenient to calculate aggregates of "spread" information. An additional syntax like =max(B2; F5; Spreadsheet003.variable) would be preferable.
Additional InformationIn some situations it is desirable to calculate an aggregate function (like a maximum or minimum) of different variables. These variables may or may not be stored next to each other.

When they are spread around one or multiple spreadsheets it would be very helpful to calculate an aggregate with a syntax like =max(B2; F5; Spreadsheet003.variable).

Of course a workaround would be to first "collect" all information next to each other and then use the aggregate function, but due to the fact that moving cells is not possible yet (see 0002472) this may also be difficult.
Tagsspreadsheet

Relationships

related to 0002472 assignedeivindkvedalen Expressions Spreadsheet - Move Cells 

Activities

eivindkvedalen

2016-04-25 17:19

developer   ~0007004

This is now supported in the recently released version 0.16.

Kunda1

2017-01-19 14:21

administrator   ~0007878

Resolving as per 0002473:0007004
Devs please confirm (and correct anything that may need it)

Issue History

Date Modified Username Field Change
2016-03-14 21:01 Spindoctor New Issue
2016-04-25 17:19 eivindkvedalen Note Added: 0007004
2017-01-19 14:19 Kunda1 Relationship added related to 0002472
2017-01-19 14:19 Kunda1 Additional Information Updated View Revisions
2017-01-19 14:21 Kunda1 Note Added: 0007878
2017-01-19 14:21 Kunda1 Status new => resolved
2017-01-19 14:21 Kunda1 Fixed in Version => 0.16
2017-01-19 14:21 Kunda1 Resolution open => fixed
2017-01-19 14:21 Kunda1 Assigned To => Kunda1
2017-01-19 14:21 Kunda1 Assigned To Kunda1 =>
2017-01-19 14:23 Kunda1 Tag Attached: spreadsheet
2017-01-31 18:03 wmayer Status resolved => closed
2017-01-31 18:03 wmayer Assigned To => eivindkvedalen