View Issue Details

IDProjectCategoryView StatusLast Update
0002471SketcherBugpublic2016-03-12 14:27
ReporterDeepSOICAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.16 
Target VersionFixed in Version0.16 
Summary0002471: In constraint context menu, 'Change Value' is always greyed out
DescriptionConstraint context menu item 'Change value' is always greyed out.
Steps To Reproduce1. New sketch
2. draw line
3. add length constraint
4. in Constraints list (on Task panel), right-click a constraint.
The menu item 'Change value' is greyed out. Yet editing the value is possible by double-clicking the constraint.
Additional InformationOS: Ubuntu 12.04.5 LTS
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.16.6597 (Git)
Build type: Unknown
Branch: master
Hash: 3ca1ec2c28d26cd6aab5c79878d9a5e82583395c
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3

http://forum.freecadweb.org/viewtopic.php?f=3&t=14644#p117509
TagsNo tags attached.

Activities

wmayer

2016-03-12 13:31

administrator   ~0006904

It worked in 0.15. The regression is caused by this commit:
https://github.com/FreeCAD/FreeCAD/commit/67800ec8c4286c21d97973ef94b5d21ed8440920

Related Changesets

FreeCAD: master a17870c9

2016-03-12 15:26:06

wmayer

Details Diff
+ fixes 0002471: In constraint context menu, 'Change Value' is always greyed out Affected Issues
0002471
mod - src/Mod/Sketcher/Gui/TaskSketcherConstrains.cpp Diff File

Issue History

Date Modified Username Field Change
2016-03-12 10:51 DeepSOIC New Issue
2016-03-12 13:31 wmayer Note Added: 0006904
2016-03-12 14:27 wmayer Changeset attached => FreeCAD Master master a17870c9
2016-03-12 14:27 wmayer Assigned To => wmayer
2016-03-12 14:27 wmayer Status new => closed
2016-03-12 14:27 wmayer Resolution open => fixed
2016-03-12 14:27 wmayer Product Version => 0.16
2016-03-12 14:27 wmayer Fixed in Version => 0.16