View Issue Details

IDProjectCategoryView StatusLast Update
0000247FreeCADBugpublic2011-01-26 14:13
Reporterfrankkuester Assigned ToJriegel 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.10 
Target VersionFixed in Version0.11 
Summary0000247: Crash on Windows with attached minimal file
DescriptionFreeCAD reproducibly crashes when opening the attached file minimal.FCStd, selecting the object (a hollow cylinder) and selecting "Duplicate selection" in the menu.

Windows wants to send a problem report to microsoft, and it's possible to view loads of info it wants to send. But it's not possible to copy that...

Regards, Frank
Additional InformationI'll try on Debian linux (squeeze) this Weekend or on Monday.
TagsNo tags attached.
FreeCAD Information

Activities

2011-01-21 16:09

 

minimal.FCStd (Attachment missing)

kuesterei

2011-01-21 19:41

reporter   ~0000544

(It's me, now with my private user name instead of the office one)

On Debian squeeze (0.10.3225), I get the same crash. Here's the output in the terminal window that started freeCAD:

$ FreeCAD 0.10, Libs: 0.10R3225
© Juergen Riegel, Werner Mayer 2001-2010
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

   Parameter not existing, write initial one
   This warning normally means that FreeCAD is running the first time
   or the configuration was deleted or moved. Build up the standard
   configuration.
   User settings not existing, write initial one
   This warning normally means that FreeCAD is running the first time
   or your configuration was deleted or moved. The system defaults
   will be reestablished for you.
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_klauncher.so
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
kdeinit4: preparing to launch /usr/bin/kbuildsycoca4
kbuildsycoca4 running...
kbuildsycoca4(13411) KBuildMimeTypeFactory::createEntry: Missing <comment> field in "audio/x-sbc.xml"
kbuildsycoca4(13411) KBuildMimeTypeFactory::createEntry: Missing <comment> field in "application/x-hcidump.xml"
kbuildsycoca4(13411) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/freecad.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(13411) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/freecad.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(13411)/kdecore (services) KServicePrivate::init: The desktop entry file "/usr/share/applications/kde/kresources.desktop" has Type= "Application" but also has a X-KDE-Library key. This works for now, but makes user-preference handling difficult, so support for this might be removed at some point. Consider splitting it into two desktop files.
kbuildsycoca4(13411) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/wine.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(13411)/kdecore (services) KServicePrivate::init: The desktop entry file "/usr/share/applications/usbview.desktop" has Type= "Applications/System/Hardware" instead of "Application" or "Service"

kbuildsycoca4(13411) KBuildServiceFactory::createEntry: Invalid Service : "/usr/share/applications/usbview.desktop"
kbuildsycoca4(13411) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/openoffice.org-startcenter.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(13411) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/jabref.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(13411) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/jabref.desktop" is not compliant with XDG standard (missing trailing semicolon).
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_kconf_update.so
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_kconf_update.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kio_trash(13417)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
Illegal storage access...

[1]+ Exit 3 freecad
(539)[21:34:02]frank@riesling:~/EyeSense$

This was in fact the first time I started freeCAD on that computer. The second time, it looks like this, after the "User setting not existing" message:

kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kio_trash(13471)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
Illegal storage access...

The first two lines (kdeinit4 and kio_trash) appear when working with the file selection dialog.

Regards, Frank

kuesterei

2011-01-21 19:42

reporter   ~0000545

I forgot: It's linux-2.6.26 on i686. The windows box is i686 and 32bit, too.

Jriegel

2011-01-26 12:02

administrator   ~0000553

I confirmed the problem on Windows 32 bit

Jriegel

2011-01-26 12:19

administrator   ~0000555

fixed in 3955

wmayer

2011-01-26 14:13

administrator   ~0000557

Just closing the item to make it disappear from the list

Issue History

Date Modified Username Field Change
2011-01-21 16:09 frankkuester New Issue
2011-01-21 16:09 frankkuester File Added: minimal.FCStd
2011-01-21 19:41 kuesterei Note Added: 0000544
2011-01-21 19:42 kuesterei Note Added: 0000545
2011-01-26 12:02 Jriegel Note Added: 0000553
2011-01-26 12:02 Jriegel Status new => confirmed
2011-01-26 12:19 Jriegel Note Added: 0000555
2011-01-26 12:19 Jriegel Status confirmed => resolved
2011-01-26 12:19 Jriegel Fixed in Version => 0.11
2011-01-26 12:19 Jriegel Resolution open => fixed
2011-01-26 12:19 Jriegel Assigned To => Jriegel
2011-01-26 14:13 wmayer Note Added: 0000557
2011-01-26 14:13 wmayer Status resolved => closed