View Issue Details

IDProjectCategoryView StatusLast Update
0002463SketcherBugpublic2018-12-20 13:00
ReporterflyhardAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.16 
Target Version0.18Fixed in Version0.18 
Summary0002463: Trim tool ignore tangent constraint to arch on circle
DescriptionIf I have an arch end connected to a circle, and also in tangent to that circle, the Trim tool ignores that connection with the arch. Trying to trim away a circle segment between the arch and a line. It trims till next valid point, like a line connected. (see attached picture of sequence)
Steps To Reproduce1. Draw a circle
2. Draw an arch with one end tangent to the circle
3. Draw two lines connected to, or through the circle (just as a break for the trim operation below)
4. Try to trim the circle segment between the arch and one of the lines
->The trim operation ignores the arch connection.
5. Use a line as a "tool", connected to where the arch connects to the circle, to stop the trim operation
Additional InformationIm running FreeCAD version 0.16.

In my attached picture, the arch is the one connected to the circle at 10 o'clock
Tagsconstraints, OCC 7.4, OCC Bug, Solver, trim, upstream

Relationships

related to 0001576 closed Slow performance using trim tool (due to Solver

Activities

Kunda1

2017-01-23 18:41

administrator  

Graphic summary.jpg (149,324 bytes)
Graphic summary.jpg (149,324 bytes)

Kunda1

2017-01-23 18:43

administrator   ~0007920

Added
Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20154
Replaced attached png with smaller sized jpg in order for better display

Kunda1

2017-04-26 02:43

administrator   ~0008766

@NormandC wrote:
Confirmed. The Report view shows this error:
Failed to trim edge: Not able to trim curve with the given index: 0

But this issue has been known for a long time, and there may be existing tickets about it.

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10893 (Git)
Build type: None
Branch: master
Hash: a75a98ef279e9e067abf5cef3a6de6f09fba2c94
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0

Kunda1

2017-04-26 02:44

administrator   ~0008767

Confirming ticket based on NormandC's feedback.

Kunda1

2017-06-28 22:53

administrator   ~0009590

Since this is a long standing bug I'm assigning to release 0.17 roadmap. If not practical can be bumped to release after that.

abdullah

2018-10-06 05:45

manager   ~0011939

The problem is that the underlying intersection routines are not detecting the intersection between the line and the circunference WHEN it is tangent. Dragging the farthest away point so as not to make it tangent leads to it being detected.

I have rewritten the intersection routine in my branch to use another OCCT function (Extrema algorithm). However, it also fails only with the tangent line.

Either it is that:
i. We are using OCCT wrongly (which is strange as for non-tangent it works nicely)
ii. These algorithms were not designed for the tangency case (which is strange as the documentation says it detects tangencies at least as segments, NbSegments).
iii. There is a bug in the OCCT routines.

Here some further investigation:
https://forum.freecadweb.org/viewtopic.php?f=10&t=31371#p260542

abdullah

2018-10-08 14:00

manager   ~0011966

Bug filed against OCCT 7.3:
https://tracker.dev.opencascade.org/view.php?id=30217

abdullah

2018-10-08 14:03

manager   ~0011967

Changed target to 0.19, as it appears to depend on OCCT.

Kunda1

2018-10-08 14:05

administrator   ~0011968

Last edited: 2018-10-08 14:05

View 2 revisions

tagged the ticket as well to keep track of upstream OCC bugs

abdullah

2018-10-28 18:32

manager   ~0012110

Work-around PR:
https://github.com/FreeCAD/FreeCAD/pull/1755

wmayer

2018-10-30 12:49

administrator   ~0012117

https://github.com/FreeCAD/FreeCAD/commit/e10068a648b2f783a2a295f132b8e36d1717fa4e

Kunda1

2018-12-20 13:00

administrator   ~0012329

Removed ticket from 0.19 roadmap and added to 0.18 instead

Issue History

Date Modified Username Field Change
2016-03-05 15:47 flyhard New Issue
2016-03-05 15:47 flyhard File Added: Graphic summary.png
2017-01-23 18:36 Kunda1 Relationship added related to 0001576
2017-01-23 18:41 Kunda1 File Added: Graphic summary.jpg
2017-01-23 18:41 Kunda1 File Deleted: Graphic summary.png
2017-01-23 18:43 Kunda1 Note Added: 0007920
2017-04-26 02:43 Kunda1 Note Added: 0008766
2017-04-26 02:44 Kunda1 Status new => confirmed
2017-04-26 02:44 Kunda1 Note Added: 0008767
2017-04-26 02:44 Kunda1 Priority high => normal
2017-04-26 02:44 Kunda1 Product Version => 0.16
2017-05-12 12:19 Kunda1 Tag Attached: Solver
2017-05-12 12:19 Kunda1 Tag Attached: trim
2017-06-28 22:35 Kunda1 Tag Attached: constraints
2017-06-28 22:53 Kunda1 Target Version => 0.17
2017-06-28 22:53 Kunda1 Note Added: 0009590
2017-12-13 15:20 Kunda1 Project Sketcher => GCS
2018-04-27 10:04 abdullah Project GCS => Sketcher
2018-06-07 19:11 Kunda1 Target Version 0.17 => 0.18
2018-10-06 05:45 abdullah Note Added: 0011939
2018-10-08 14:00 abdullah Note Added: 0011966
2018-10-08 14:02 abdullah Target Version 0.18 => 0.19
2018-10-08 14:03 abdullah Note Added: 0011967
2018-10-08 14:04 Kunda1 Tag Attached: OCC Bug
2018-10-08 14:04 Kunda1 Tag Attached: upstream
2018-10-08 14:04 Kunda1 Tag Attached: OCC 7.4
2018-10-08 14:05 Kunda1 Note Added: 0011968
2018-10-08 14:05 Kunda1 Note Edited: 0011968 View Revisions
2018-10-28 18:32 abdullah Note Added: 0012110
2018-10-30 12:49 wmayer Assigned To => abdullah
2018-10-30 12:49 wmayer Status confirmed => closed
2018-10-30 12:49 wmayer Resolution open => fixed
2018-10-30 12:49 wmayer Fixed in Version => 0.18
2018-10-30 12:49 wmayer Note Added: 0012117
2018-12-20 13:00 Kunda1 Target Version 0.19 => 0.18
2018-12-20 13:00 Kunda1 Note Added: 0012329