View Issue Details

IDProjectCategoryView StatusLast Update
0002451FreeCADBugpublic2016-02-20 09:20
Reporters-lightAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platform64bitOSKubuntuOS Version15.10
Product Version 
Target VersionFixed in Version0.16 
Summary0002451: FreeCAD crashes on selecting Mirrowed Part
DescriptionFreeCAD 0.16, Libs: 0.16R6431 (Git) (daily debs)

with the appended FreeCAD file every time i open it and click on the mirrored part object - in the tree-view or in the 3D-view FreeCAD crashes.
i have copied the log information from the terminal in the additional information field.
Additional Informationstefan@stefan-latitude:~$ freecad
FreeCAD 0.16, Libs: 0.16R6431 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2015
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

--accepting rule at line 275 ("Constraints")
--accepting rule at line 149 ("[")
--accepting rule at line 251 ("2")
--(end of buffer or a NUL)
--accepting rule at line 149 ("]")
--(end of buffer or a NUL)
--EOF (start condition 0)
--accepting rule at line 158 ("-")
--accepting rule at line 149 ("(")
--accepting rule at line 248 ("10.3")
--accepting rule at line 164 ("mm")
--accepting rule at line 149 (")")
--accepting rule at line 144 (" ")
--accepting rule at line 149 ("/")
--accepting rule at line 144 (" ")
--(end of buffer or a NUL)
--accepting rule at line 251 ("2")
--(end of buffer or a NUL)
--EOF (start condition 0)
*** Abort *** an exception was raised, but no catch was found.
        ... The exception is:SIGSEGV 'segmentation violation' detected. Address 0
stefan@stefan-latitude:~$
TagsNo tags attached.

Relationships

duplicate of 0002389 closedeivindkvedalen Crash systematic on the 10th sketch when employing a cavity. 

Activities

s-light

2016-02-18 12:31

reporter  

SDIP_4L.fcstd (Attachment missing)

s-light

2016-02-18 12:35

reporter  

FreeCAD.log (Attachment missing)

wmayer

2016-02-18 16:47

administrator   ~0006834

Which of the objects is the mirrored part object. I cannot find one.
Nevertheless the bug looks similar to that in 0002436. Can you get the latest sources from master and check if this fixes the problem, please?

s-light

2016-02-19 11:20

reporter  

FreeCAD_MirrorPart.png (Attachment missing)

s-light

2016-02-19 11:23

reporter   ~0006835

I have added a screenshot where i hover the mirrored part with the mouse.
in the treeview its 'Pin1_Sweep (Mirror #1)'
my current version:
OS: Ubuntu 15.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6433 (Git)
Build type: None
Branch: master
Hash: 183f8dfebe92323c6bf4f0a378b062189eb95cae
Python version: 2.7.10
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
(--> 2016/02/17 18:36:16)
with this it chrashes if i click the highlighted object in the 3d view or click on the entry 'Pin1_Sweep (Mirror #1)' in the tree view.

as soon as i can update i will try again.

wmayer

2016-02-19 14:20

administrator   ~0006836

Maybe you have uploaded the wrong fcstd file. In the attached file there is definitely no object 'Pin1_Sweep (Mirror #1)'

s-light

2016-02-19 15:39

reporter  

SDIP_4L_CRASHES.fcstd (Attachment missing)

s-light

2016-02-19 15:40

reporter   ~0006837

i have uploaded the file again. seems i have picked the backup file without the mirror...

wmayer

2016-02-20 09:20

administrator   ~0006838

I have checked out git 69c241ba8972b which is the status before the fixes and this showed the crash exactly at the same position as 0002389. Going back to current master everything works properly again.

Issue History

Date Modified Username Field Change
2016-02-18 12:31 s-light New Issue
2016-02-18 12:31 s-light File Added: SDIP_4L.fcstd
2016-02-18 12:35 s-light File Added: FreeCAD.log
2016-02-18 16:47 wmayer Note Added: 0006834
2016-02-19 11:06 wmayer Status new => feedback
2016-02-19 11:20 s-light File Added: FreeCAD_MirrorPart.png
2016-02-19 11:23 s-light Note Added: 0006835
2016-02-19 11:23 s-light Status feedback => new
2016-02-19 14:20 wmayer Note Added: 0006836
2016-02-19 14:20 wmayer Status new => feedback
2016-02-19 15:39 s-light File Added: SDIP_4L_CRASHES.fcstd
2016-02-19 15:40 s-light Note Added: 0006837
2016-02-19 15:40 s-light Status feedback => new
2016-02-19 22:29 wmayer Relationship added duplicate of 0002389
2016-02-20 09:20 wmayer Note Added: 0006838
2016-02-20 09:20 wmayer Status new => closed
2016-02-20 09:20 wmayer Resolution open => fixed
2016-02-20 09:20 wmayer Fixed in Version => 0.16