View Issue Details

IDProjectCategoryView StatusLast Update
0002441PartDesignBugpublic2018-08-26 15:21
ReporterTomas Assigned Toabdullah  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.15 
Target Version0.17Fixed in Version0.17 
Summary0002441: Doing a pad of a sketch "Up to face" fails
DescriptionDoes not pad the entire way to the selected face.
It is possible to pad by "dimension" instead so I cannot see why "up to face" wouldnt work.

Thank you for a great software!
Steps To ReproduceIn attaced file the last step.
Pad008 of Sketch017 up to face "Face5" fails.
Additional InformationForum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=20461
TagsNo tags attached.

Relationships

related to 0003141 closedwmayer Unexpected behaviour using pad to face on padded shape binder 

Activities

Tomas

2016-02-07 20:22

reporter  

värmeväxlare.FCStd (299,596 bytes)

Kunda1

2017-02-02 01:26

administrator   ~0008163

@Tomas please test on latest stable
Also, when you reply, if you don't mind including your:
1) Help > About FreeCAD > Copy to clipboard
2) Create a forum thread and bi-directionally link ticket <=> thread

Tomas

2017-02-03 18:04

reporter   ~0008194

Hello Kunda,
Sorry I am not sure how all these forums work..
Tried to do the same operation now and in the attached figure I marked the face5 to wich I was trying to pad. As you can see the padding is still not reaching face5.
BR
Tomas

Kunda1

2017-02-03 20:56

administrator  

version.jpg (24,369 bytes)
version.jpg (24,369 bytes)

Kunda1

2017-02-03 20:58

administrator  

face5-1.jpg (92,410 bytes)
face5-1.jpg (92,410 bytes)

Kunda1

2017-02-03 21:03

administrator   ~0008195

@Tomas I've created a forum thread for you, see https://forum.freecadweb.org/viewtopic.php?f=8&t=20461

normandc

2017-02-04 04:47

manager   ~0008204

Tomas,
Please read the READ THIS BEFORE REPORTING link in the "ISSUES" menu, it's just above "REPORT ISSUE" which you had to click to create this report.

As explained in that link, we ask that users mention any potential bug on the forum *before* creating a report. Your model is rather complicated, and to validate this issue it would have been best to reproduce the bug with a model as simple as possible.

@Kunda1
Tomas is already using the latest stable available on Windows as shown in his screenshot (0.16.6706). Agreed that it's best to provide this info in text format.

normandc

2017-02-04 04:53

manager   ~0008205

I confirm the problem on Tomas' model, but I'm unable to reproduce this issue on simpler test cases. I will have to analyze Tomas' model further.

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6707 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 5465bc47c95db45e0be85dc0e2872419efadce0f
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

normandc

2017-02-04 05:08

manager   ~0008206

Tomas,

The use of a Part --> Refine shape on Pocket003, resulting in Pocket004, has broken your model's history. Part Refine shape creates an independent solid that is not linked to the object it's based to. It is bad practice to base further operations on such an object.

The LinearPattern feature produces an invalid solid with self-intersect errors. This can be seen by using Part Check Geometry with extra BOP check (https://www.freecadweb.org/wiki/index.php?title=Part_CheckGeometry)

There may be a bug here, but to confirm we would need a model with no errors to begin with. Which is why this should be addressed in the forum first, for which this tracker is not the proper place.

Tomas

2017-02-05 20:28

reporter   ~0008220

@Kunda1 Thanks!

I tried to correct the linear pattern operation that obviously created a non-valid object but after that the changes I made did not follow on in the rest of the operations and in the end I was there with just a bunch of disaster.

I am sorry guys, I am like a grandpa compared to you when it comes to freecad.

I have already made a fool of myself to normandc once this week..

Maybe we should just drop this Issue.

I thank you for a nice software and a great effort.

BR

Tomas

Kunda1

2017-12-07 11:57

administrator   ~0010542

@normandc can you try to reproduce the bug without the example model?

normandc

2017-12-31 13:57

manager   ~0010646

@Kunda1 I'm afraid I can't.

abdullah

2018-01-02 17:47

manager   ~0010673

If I open the original file, the padding goes up to face. Then I can no longer work with the model with 0.17, as it is not PDN. I am closing this ticket as we can not reproduce the bug.

@Tomas

I make a fool of myself everyday. If you happen to find any bug, try to report it following the procedure. It is in place so that very competent people, like Normand makes sure it is a bug and help you shape the form of the bug report. It saves time for everybody, specially for developers. I hope to see you around again :)

Issue History

Date Modified Username Field Change
2016-02-07 20:22 Tomas New Issue
2016-02-07 20:22 Tomas File Added: värmeväxlare.FCStd
2017-02-02 01:26 Kunda1 Note Added: 0008163
2017-02-02 01:26 Kunda1 Status new => feedback
2017-02-03 18:02 Tomas File Added: version.jpg
2017-02-03 18:02 Tomas File Added: face5.jpg
2017-02-03 18:04 Tomas Note Added: 0008194
2017-02-03 18:04 Tomas Status feedback => new
2017-02-03 20:56 Kunda1 File Deleted: version.jpg
2017-02-03 20:56 Kunda1 File Added: version.jpg
2017-02-03 20:58 Kunda1 File Deleted: face5.jpg
2017-02-03 20:58 Kunda1 File Added: face5-1.jpg
2017-02-03 21:02 Kunda1 Additional Information Updated View Revisions
2017-02-03 21:02 Kunda1 Tag Attached: #pending
2017-02-03 21:03 Kunda1 Note Added: 0008195
2017-02-04 04:47 normandc Note Added: 0008204
2017-02-04 04:53 normandc Note Added: 0008205
2017-02-04 05:08 normandc Note Added: 0008206
2017-02-04 12:18 Kunda1 Status new => feedback
2017-02-05 20:28 Tomas Note Added: 0008220
2017-02-05 20:28 Tomas Status feedback => new
2017-09-24 15:36 wmayer Status new => confirmed
2017-09-24 15:36 wmayer Target Version => 0.17
2017-12-07 11:57 Kunda1 Note Added: 0010542
2017-12-31 13:57 normandc Note Added: 0010646
2018-01-02 17:47 abdullah Note Added: 0010673
2018-01-02 17:47 abdullah Assigned To => abdullah
2018-01-02 17:47 abdullah Status confirmed => closed
2018-01-02 17:47 abdullah Resolution open => unable to reproduce
2018-01-02 17:47 abdullah Fixed in Version => 0.17
2018-01-05 21:58 wmayer Relationship added related to 0003141
2018-08-26 15:21 Kunda1 Tag Detached: #pending