View Issue Details

IDProjectCategoryView StatusLast Update
0002412FreeCADBugpublic2016-01-20 13:48
ReporterCptMonkeyFistAssigned Tojmaustpc 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformPCOSWindowsOS VersionWin 8 x64
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002412: Pad/Pocket to first will not refine with parallel faces
DescriptionTake two parallel planes that when looking down at their faces one is on top of the other. Create a sketch of a circle on the top plane and center it on the edge of the plane that overlaps the bottom plane. Pocket to first. Refine model should refine away the circle but it does not.
Steps To Reproduce1. Create a standard 10x10 mm cube at the origin.
2. Select the front face and create a new sketch.
3. Create a rectangle that is 3mm by 10mm in the X/Y plane and whose bottom left corner is at the origin. It should look like a rectangle that takes up the left side of the cube.
4. Pad by 3mm.
5. Create a new sketch on the padded face (the one facing the same direction as the face you sketched on previously but is part of the new geometry).
6. Draw a circle that is at 3mm by 5mm in the X/Y plane with a radius of 2mm.
7. Pocket with type "to first"
8. Refine the model.

Expected: Geometry of the circle is refined away from the original cube.
Actual: Geometry of the circle remains.

Refinement will work if you specify the depth of the pocket manually. This appears to have worked in version 0.14 when you watch the tutorial at the link given in Additional information.
Additional InformationExpected with Pad: https://youtu.be/cRFsW_FhyP4?t=13m52s
Expected with Pocket: https://youtu.be/cRFsW_FhyP4?t=21m44s
TagsNo tags attached.

Activities

CptMonkeyFist

2016-01-20 05:59

reporter  

Pictures.zip (Attachment missing)

jmaustpc

2016-01-20 13:47

manager   ~0006735

Hi and thank you for your time creating this ticket.

However I think it would be best to discuss these matters first on the forums where more eyes see it, before you decide it is a bug and create the ticket. That way we can save a lot of poor quality or unnecessary tickets.

FreeCAD 0.15 is now almost obsolete being more than 1500 commits behind master.

Also it would speed up the process of others testing this in a more recent FreeCAD if you had attached the fcstd file.

Anyway the problem is not there for me, so I assume it has been fixed. It may be a FreeCAD or OCE update or a setting or Linux. Feel free to discuss this further on the forums if you wish and if it later turns out to be platform specific or requires reopening this ticket, we can do so.

If you are still using 0.15 I recommend you update to a Windows snapshot release which has a huge number of bug fixes and new features.


OS: Ubuntu 12.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6240 (Git)
Build type: Debug
Branch: master
Hash: fa42bc451ab6933a441d7be3680c1d17a25c33e8
Python version: 2.7.3
Qt version: 4.8.2
Coin version: 3.1.3
OCC version: 6.9.1.oce-0.18-dev

Issue History

Date Modified Username Field Change
2016-01-20 05:59 CptMonkeyFist New Issue
2016-01-20 05:59 CptMonkeyFist File Added: Pictures.zip
2016-01-20 13:47 jmaustpc Note Added: 0006735
2016-01-20 13:48 jmaustpc Status new => closed
2016-01-20 13:48 jmaustpc Assigned To => jmaustpc
2016-01-20 13:48 jmaustpc Resolution open => no change required
2016-01-20 13:48 jmaustpc Fixed in Version => 0.16