View Issue Details

IDProjectCategoryView StatusLast Update
0002401FreeCADBugpublic2016-05-05 19:50
Reporterideechaniz Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0002401: Freecad 0.16, sketcher doesn't allow save as
DescriptionI am using sketcher and I saved a file, just in case. I want to save the same file with another name and continue editing and save as is disabled so I can not use a different name for the file.
Steps To ReproduceTry to save as a diferent file name
Additional InformationI am using freecad Daily for Ubuntu.

OS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6203 (Git)
Build type: None
Branch: master
Hash: 64a20a83ccf14c5eea43b0f5b0f5191db014c022
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2016-01-11 02:08

administrator   ~0006709

Cannot reproduce that problem.. Are you sure you did close the sketch edition before trying to save?

jmaustpc

2016-01-28 14:39

manager   ~0006768

Hi Yorik
same as you here, I only see "save as" greyed out if I still have a sketch in edit mode.

This raises the question that if we allow "save" should we also allow 'save as" when in sketch edit mode, but perhaps that could lead to unintended consequences?

I think this is another case that would have been more efficiently handled on the Help forum and then refined into a bug ticket if appropriate.


ideechaniz, thank you for taking the time to create this ticket but its almost always best to discuss matters on the Help forum first, so as to help keep the number of bug tickets low and their quality high. And then past a link to the Help forum topic into the ticket.

OS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6344 (Git)
Build type: Debug
Branch: master
Hash: 2eb194776b8c69e64840e9f62a7cb66abdb8090a
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.9.1.oce-0.18-dev

bejant

2016-02-23 19:00

reporter   ~0006848

This is for the devs: If you allow the user to "Save As" while in Sketcher, then do you add another button for "Save As" in the toolbar? Or just allow the user to use Ctrl + Shift + S for "Save As" while in Sketcher?

I think this will not be a frequently used tool and another button adds clutter to the toolbar for little gain. A better option might be for the user to increase the "Preferences > Save Up To N Backup Copies", hit the Save button while in Sketcher, and just rename the backup. The user still has to key in a new file name using either method...

jmaustpc

2016-03-01 15:21

manager   ~0006872

I was talking about the "save" and "save as" in the file menu, I agree that another tool bar button would be a waste of tool bar space.

Related Changesets

FreeCAD: master 4eada9a4

2016-05-05 21:49:54

wmayer

Details Diff
+ fixes 0002401: Freecad 0.16, sketcher doesn't allow save as Affected Issues
0002401
mod - src/Gui/CommandDoc.cpp Diff File

Issue History

Date Modified Username Field Change
2016-01-10 21:26 ideechaniz New Issue
2016-01-11 02:08 yorik Note Added: 0006709
2016-01-11 02:08 yorik Status new => feedback
2016-01-28 14:39 jmaustpc Note Added: 0006768
2016-02-23 19:00 bejant Note Added: 0006848
2016-03-01 15:21 jmaustpc Note Added: 0006872
2016-05-05 19:50 wmayer Changeset attached => FreeCAD Master master 4eada9a4
2016-05-05 19:50 wmayer Assigned To => wmayer
2016-05-05 19:50 wmayer Status feedback => closed
2016-05-05 19:50 wmayer Resolution open => fixed
2016-05-05 19:50 wmayer Fixed in Version => 0.17