View Issue Details

IDProjectCategoryView StatusLast Update
0002387FreeCADBugpublic2017-07-11 20:06
ReporterJLB85FRAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformpcOSwindowsOS VersionXP
Product Version0.15 
Target VersionFixed in Version 
Summary0002387: Unexpected position when rotating multiple objects
DescriptionWhen rotation multiple objects selected together, all seems to be rotated properly, but after refresh, some of the objects are not at the expected place.
Undo and Redo features also have unexpected results. This will need another BT when I will be able to reproduce.
See attached file.
Steps To Reproduce1) Select Draft
2) Draw 2 lines
3) Select 2 lines from the tree view OR using ctrl+click on each
4) Select Rotate function
5) Ctrl+click center
6) Ctrl+click base-angle
7) Ctrl+click and rotate 315 degrees
RESULT: After finishing the objects are in the expected position.
8) F5 (aka Refresh display)
RESULT: One of the objects is not in their expected position
9) Undo
RESULT: sometimes it will restore correctly and sometimes not
10) F5 and undo
RESULT: chaos
11: F5 and redo
RESULT: chaos
Tagsrotate, undo

Relationships

related to 0002504 closedickby PartDesign Crash in pad function after undoing some operations 
related to 0002055 closedkkremitzki FreeCAD Undo and redo of fillet restore it incorrectly 

Activities

JLB85FR

2016-01-01 17:19

reporter  

bug rotate.pdf (Attachment missing)

Kunda1

2017-01-17 16:57

administrator   ~0007841

Last edited: 2017-01-17 17:04

View 2 revisions

I added the step-by-step portion (for the PDF file) with some embellishments.
I tried to reproduce but couldn't get F5 AKA Refresh to work.
http://forum.freecadweb.org/viewtopic.php?f=10&t=19980

Kunda1

2017-05-01 23:08

administrator   ~0008842

@NormandC can you take a stab at this?

Kunda1

2017-05-13 21:39

administrator   ~0008997

Closing as testers were not able to reproduce.

Issue History

Date Modified Username Field Change
2016-01-01 17:19 JLB85FR New Issue
2016-01-01 17:19 JLB85FR File Added: bug rotate.pdf
2017-01-17 16:49 Kunda1 Tag Attached: rotate
2017-01-17 16:57 Kunda1 Note Added: 0007841
2017-01-17 16:57 Kunda1 Steps to Reproduce Updated View Revisions
2017-01-17 16:57 Kunda1 Tag Attached: undo
2017-01-17 17:04 Kunda1 Note Edited: 0007841 View Revisions
2017-02-04 03:44 Kunda1 Status new => feedback
2017-02-04 03:44 Kunda1 Tag Attached: #pending
2017-02-04 03:45 Kunda1 Relationship added related to 0002504
2017-02-04 03:46 Kunda1 Relationship added related to 0002055
2017-05-01 23:08 Kunda1 Note Added: 0008842
2017-05-13 21:39 Kunda1 Status feedback => closed
2017-05-13 21:39 Kunda1 Resolution open => unable to reproduce
2017-05-13 21:39 Kunda1 Note Added: 0008997
2017-07-11 20:06 Kunda1 Tag Detached: #pending