View Issue Details

IDProjectCategoryView StatusLast Update
0002373FreeCADBugpublic2016-01-19 02:06
Reporternmac2011Assigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformUbuntuOSTrusty TarOS Version14.04
Product Version 
Target VersionFixed in Version0.16 
Summary0002373: When Measuring in the distance between two external geometry Freecad crashes
DescriptionWhile I don't really see any reason why one would want to do this I feel as though it definitely should not cause the the program to crash and close.


OS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6061 (Git)
Build type: None
Branch: master
Hash: f958dadb698f83d6ce450cf4a9decb3515740c4c
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Steps To Reproduce1. Create a sketch in part design
2. Pad the sketch
3. Create a new sketch on the one of the faces of the pad
4. select 2 external geometries
5. Put a constraint length constraint between them
    Program Crashes
An error message like can not put length constraints between external geometries would be nice.
TagsNo tags attached.

Relationships

duplicate of 0002372 closedwmayer Application terminates on attempt to change external geometry from a sketch 

Activities

ChapaikinVA

2015-12-19 16:05

reporter   ~0006619

The same is desribed in: http://freecadweb.org/tracker/view.php?id=2372

wmayer

2015-12-24 15:45

administrator   ~0006632

Since v0.16 "non-driving" constraints have been added which allows to also add constraints to external geometries. This can be useful to e.g. measure distances or angles and so on.

Now it seems that with a newer Eigen version something has been broken. Ubuntu 14.04 uses Eigen 3.2.0 while Ubuntu uses 3.0.5 and there no crash happens. On Windows I have Eigen 3.2.5 and there I get a crash too.

Related Changesets

FreeCAD: master 632eaead

2015-12-25 09:47:25

wmayer

Details Diff
+ fixes 0002372: Application terminates on attempt to change external geometry from a sketch
+ fixes 0002373: When Measuring in the distance between two external geometry Freecad crashes
Affected Issues
0002372, 0002373
mod - src/Mod/Sketcher/App/planegcs/GCS.cpp Diff File

Issue History

Date Modified Username Field Change
2015-12-19 13:21 nmac2011 New Issue
2015-12-19 16:05 ChapaikinVA Note Added: 0006619
2015-12-20 23:13 yorik Relationship added related to 0002372
2015-12-24 15:45 wmayer Note Added: 0006632
2015-12-24 15:49 wmayer Relationship replaced duplicate of 0002372
2015-12-24 15:49 wmayer Assigned To => abdullah
2015-12-24 15:49 wmayer Status new => assigned
2015-12-25 09:38 wmayer Changeset attached => FreeCAD Master master 632eaead
2015-12-25 09:38 wmayer Assigned To abdullah => wmayer
2015-12-25 09:38 wmayer Status assigned => closed
2015-12-25 09:38 wmayer Resolution open => fixed
2016-01-19 02:06 yorik Fixed in Version => 0.16