View Issue Details

IDProjectCategoryView StatusLast Update
0002371SketcherFeaturepublic2016-02-26 16:52
ReporterRuneAssigned Toyorik 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target Version0.16Fixed in Version0.13 
Summary0002371: One expects zoom to zoom where the mouse is
DescriptionIn Sketch the zoom should not zoom the center of the view but where the user currently hold the mouse pointer.
TagsNo tags attached.

Activities

yorik

2015-12-20 23:22

administrator   ~0006622

This is the case already, no?

wmayer

2015-12-21 13:57

administrator   ~0006624

This feature is implemented since at least v0.13.
To activate it go to the Preferences > Display > 3d view and enable Zoom at cursor

Rune

2015-12-21 14:20

reporter   ~0006625

Yes, sorry. The issue is then that this is not obvious to the newcomer and should be checked by default. BTW. it's too 'nerdy' that newcomers should start changing presets to get what should be expected state of the art behavior.

yorik

2016-02-23 14:25

administrator   ~0006846

I'll change this setting to True by default, I think it's indeed what most will consider the "normal" behaviour.

Related Changesets

FreeCAD: master 83f87ba3

2016-02-26 17:51:39

yorik

Details Diff
Turned Zoom At Cursor option True by default - fixes 0002371 Affected Issues
0002371
mod - src/Gui/DlgSettings3DView.ui Diff File
mod - src/Gui/NavigationStyle.cpp Diff File
mod - src/Gui/View3DInventor.cpp Diff File

Issue History

Date Modified Username Field Change
2015-12-17 14:51 Rune New Issue
2015-12-20 23:22 yorik Note Added: 0006622
2015-12-20 23:23 yorik Project Drawing => Sketcher
2015-12-21 13:57 wmayer Note Added: 0006624
2015-12-21 13:57 wmayer Status new => closed
2015-12-21 13:57 wmayer Resolution open => no change required
2015-12-21 13:57 wmayer Fixed in Version => 0.13
2015-12-21 14:20 Rune Note Added: 0006625
2015-12-21 14:20 Rune Status closed => feedback
2015-12-21 14:20 Rune Resolution no change required => reopened
2016-02-23 14:25 yorik Note Added: 0006846
2016-02-23 14:25 yorik Assigned To => yorik
2016-02-23 14:25 yorik Status feedback => assigned
2016-02-23 14:27 yorik Target Version => 0.16
2016-02-26 16:52 yorik Changeset attached => FreeCAD Master master 83f87ba3
2016-02-26 16:52 yorik Status assigned => closed