View Issue Details

IDProjectCategoryView StatusLast Update
0002369FreeCAD[All Projects] Generalpublic2017-07-12 11:37
ReporterplaesAssigned Tovejmarie 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0002369: STEP import is not grouping parts
Description.step file imports all the internal parts (not sure what's the proper term for these) into single flat list and doesn't perform any grouping.
Steps To Reproduce1. Import step file
2. Observe the list of elements in "Labels & Attributes" section:

Under "Application -> Unnamed" there's a flat list of all the lowest-level objects defined in the file.

* Board
* Extruded
* Extruded001
* Extruded002
...
* Extruded260
* Cylinder
* Extruded261
* Sphere
* Sphere001
...
And so on..


When importing the same file in Solidworks, the object list contains a tree of properly grouped and named elements (Board, C57, C56, C55, LC1, C54, and so on).
Additional InformationSeems like the STEP import is built on top of https://github.com/stepcode/stepcode but it's now outdated.

Per the forum thread:
"Freecad does not use stepcode but the occ step importer. And it does not group the imports because there is no functionality for that available in Freecad, hence groups are ignored."
Tagsimport, STEP

Relationships

related to 0001738 closedvejmarie File formats IDF Import failure if STP file consists of multiple Objects 

Activities

plaes

2015-12-13 15:13

reporter  

arietta.step.gz (Attachment missing)

wmayer

2015-12-16 18:37

administrator   ~0006614

Forum link: http://forum.freecadweb.org/viewtopic.php?f=8&t=13534

plaes

2015-12-16 19:22

reporter  

solidworks-step-import.png (Attachment missing)

Kunda1

2017-03-27 12:53

administrator   ~0008714

Linked to 0001738

Kunda1

2017-07-11 11:02

administrator   ~0009709

@plaes do you mind re-uploading step file and screenshots ? (I know it was a long while ago but since then we had a backup failure for the tracker and lost attachments). Thanks!

Kunda1

2017-07-11 11:06

administrator   ~0009710

@wmayer wrote:
wmayer wrote


In FreeCAD there is a hidden function to get the structure of a STEP or IGES file (or better the structure of the ocaf document). You can load it with:


import ImportGui
ImportGui.ocaf("arietta.step")


which shows a tree with all the content. Does anybody know how to get the grouping information out of this?
@plaes in the bug report you said that SW shows the grouping properly. How many groups are there and how many levels? Maybe an image would help.

I tried the file with CADExchanger which shows also some group structure but they are labeled "=> [0:1:1:2]" and so on but not "Board", "C57", ...

Kunda1

2017-07-11 11:28

administrator   ~0009714

Per @plaes
"The URL of the step file is at http://terzo.acmesystems.it/download/mechanicals/arietta.step

Kunda1

2017-07-12 11:37

administrator   ~0009731

Thanks to vejmarie's FreeCAD Pull Request 871 FC now groups parts. Thanks!
Closing ticket.

Issue History

Date Modified Username Field Change
2015-12-13 15:13 plaes New Issue
2015-12-13 15:13 plaes File Added: arietta.step.gz
2015-12-16 18:37 wmayer Note Added: 0006614
2015-12-16 19:22 plaes File Added: solidworks-step-import.png
2017-01-16 09:02 Kunda1 Tag Attached: STEP
2017-02-04 12:20 Kunda1 Relationship added related to 0001738
2017-03-27 12:53 Kunda1 Note Added: 0008714
2017-07-11 11:02 Kunda1 Note Added: 0009709
2017-07-11 11:05 Kunda1 Additional Information Updated View Revisions
2017-07-11 11:06 Kunda1 Note Added: 0009710
2017-07-11 11:07 Kunda1 Tag Attached: import
2017-07-11 11:28 Kunda1 Note Added: 0009714
2017-07-12 11:34 Kunda1 Tag Attached: #pending
2017-07-12 11:37 Kunda1 Assigned To => vejmarie
2017-07-12 11:37 Kunda1 Status new => closed
2017-07-12 11:37 Kunda1 Resolution open => fixed
2017-07-12 11:37 Kunda1 Fixed in Version => 0.17
2017-07-12 11:37 Kunda1 Note Added: 0009731
2017-07-12 11:37 Kunda1 Tag Detached: #pending