View Issue Details

IDProjectCategoryView StatusLast Update
0002347FreeCADBugpublic2015-12-28 12:55
ReporterjwakelyAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002347: freecad fails to build with Boost 1.60.0
DescriptionI have tried to build freecad with Boost 1.60.0 beta now available, and it fails due to the use of the boost::re_detail namespace in FeaturePage.cpp:

/builddir/build/BUILD/freecad-0.15.4671/src/Mod/Drawing/App/FeaturePage.cpp: In member function 'virtual App::DocumentObjectExecReturn* Drawing::FeaturePage::execute()':
/builddir/build/BUILD/freecad-0.15.4671/src/Mod/Drawing/App/FeaturePage.cpp:198:24: error: 'boost::re_detail' has not been declared
                 boost::re_detail::string_out_iterator<std::string > out(newfragment);
                        ^


That namespace was renamed by this commit https://github.com/boostorg/regex/commit/6ffcc5ede027e3b81df56c11abab5ec43b5f8d04
Steps To ReproduceDownload the Boost 1.60.0 beta, install it, try to build freecad.
Additional InformationThat namespace looks like an implementation detail, not part of the public API, so probably shouldn't be used anyway.

It looks like std::back_inserter(newfragment) could be used instead of re_detail::string_out_iterator

A quick hack would be to change re_detail to BOOST_REGEX_DETAIL_NS and define that near the top of the file when it isn't already defined by the Boost.Regex headers:

#ifndef BOOST_REGEX_DETAIL_NS
#define BOOST_REGEX_DETAIL_NS re_detail
#endif

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master e0683f4d

2015-12-28 13:54:40

wmayer

Details Diff
+ fixes 0002347: freecad fails to build with Boost 1.60.0 Affected Issues
0002347
mod - src/Mod/Drawing/App/FeaturePage.cpp Diff File
mod - src/Mod/Drawing/App/FeatureViewSymbol.cpp Diff File

Issue History

Date Modified Username Field Change
2015-11-27 21:39 jwakely New Issue
2015-12-28 12:55 wmayer Changeset attached => FreeCAD Master master e0683f4d
2015-12-28 12:55 wmayer Assigned To => wmayer
2015-12-28 12:55 wmayer Status new => closed
2015-12-28 12:55 wmayer Resolution open => fixed
2015-12-28 12:55 wmayer Fixed in Version => 0.16